Showing results for 
Search instead for 
Did you mean: 

Asus Smart Gesture - Automatic Touchpad disable- function - Windows 10 - G751JY

Level 7

I have a weird Problem with the Asus SmartGesture drivers on my Asus G751JY. Recently I've upgraded to Windows 10 and I recognized, that when I'm enabling the automatic TouchPad- Disabling- Function in the SmartGesture Settings, my Touchpad instantly disables, even I haven't connected an external USB mouse (Roccat Kone XTD). Even ATK OSD gives me correct notifications, when I'm plugging in an USB Mouse. But when I'm disconnecting USB, it says "Touchpad enabled" but it's still not working. I have to hit the FN- Key combination to enable my TouchPad, but then the automatic functionality in SmartGesture disables itself.

I tried to find out, what causes this issue. Newest drivers installed, newest SmartGesture SW...

Then I looked inside my Device Manager and I saw two Mouse Input devices. First Named "Asus Touchpad" (or if you use the Elantech- Drivers "Elantech Trackpad" and a mysterious HiD Mouse input Device. But my external Mouse isn't connected. When I connect my external mouse, a third Mouse input device appears.

I can't remember, seeing two mice I Device Manager, representing the internal TouchPad. Have some of you the Same issue in Windows 10 an /- or do some of you have also two "internal" Mouse input device in Windows 8.1's device Manager?

Thank you guys


Level 10
Did you try uninstall old atk drivers and downloading the new windows 10 atk drivers? I have done a ton of g751 upgrades and never seen that it always shows elan input device though its possible if you bought yours in another country you may have different hardware.
3d printed parts and accessories for the G751. You know you want something better than OEM ->[SIGPIC][/SIGPIC]

Level 7
Yes, i've installed all newest Windows 10 capable Software and Drivers including ATK and so on. Problem still persists. Do you have Windows 8.1 curently installed? How Many "internal" Pointing Devices do you have shown in the Device Manager?

I guess not, that this isue has something to do with different countries. My OS Base is still English, but ASUS packs in a German Language MUI. I guess thats all. HW should be the same, like in other countries. The interesting Thing is, that you do not Need to install the Elan Input Device Drivers. Asus Smart Gesture already Comes with an own Driver and the "Elan Input Device" get's renamed to "ASUS TouchPad" but the "HiD konforme Maus" (HiD Mouse) never changes. Still there... iritating AsusSmart Gesture Touchpad- Auto disable....

Level 7
Good News,

i solved it! I've forced Windows to put the HiD Device into a different category. I clicked on update Driver on "HID konforme Maus" (HID compatible Mouse) and choosed a differen one from a Driver list. There was a second compatible Device named "Hid-Konformes Gerät" (HID compatible Device). I have selected it and the misterious Device moved to the "Eingabegeräte" (Input- Devices) - section! Under "Mäuse und andere Zeigegeräte" (Mice and other pointing devices) only the "ASUS Touchpad" remains. See Screenshots below

After that, the auto- disable function is working flawlessly! :DD