cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Mouse BSOD

Retired
Not applicable
Hey all,

I bought the G73JW-A1 and LOVE IT! Except for one thing, the mouse. The mouse works great when it works. I installed the drivers from Asus's website and the mouse stopped working. Then I used the touchpad to access the Asus ROG Mouse software and Windows 7 64-Bit gets a Blue Screen of Death. I wasn't able to uninstall the software either. I had to do a System restore to a day earlier to get it working again without the software. I figured it might be a fluke, so reinstalled. It did the same thing and I had to use System Restore to get the system going again.

Since the mouse seemed to work without any problem without the software, I started using it that way. After a day or two I get a message from Windows that it couldn't install the USB device and an error message. The mouse stops working. I can move it to a different USB port, and it starts working again for a few days until the error.

I even tried this with a Dell computer I have and the SAME thing happened with the mouse stopping working.

Any ideas? I tried calling Asus tech support but was on hold too long.

Thanks! -Ken
11,794 Views
7 REPLIES 7

IM0001
Level 8
It sounds like the mouse itself could be bad so getting a hold of ASUS for an RMA for the mouse would be the best bet. Have you tried E-Mail for RMA support?

Retired
Not applicable
I am going to contact them today to see if they can get me going. It really stinks because I love the feel of this mouse. I will report back what they tell me.

Lezz
Level 7
Hm.. Maybe I've got something like this.... There were a number of BSODs "BUGCODE_USB_DRIVER" when only USB device plugged in was ASUS mouse which come came with G73jw-A1.



BigKenW,
any luck?
i've got full memory dump on this case... Going to contact them too..


If someone's interested, here are dumps:
mini: http://narod.yandex.ru/disk/start/13.dl2c-narod.yandex.ru/12074372001/h39956419f8979da1b0e564fe944df...
full: http://narod.ru/disk/12083925001/MEMORY.7z.html

Can I use the ASUS RAZor mouse software with my Logitech Performance Mouse MX?
-ASUS ROG G73SW-3DE-
-Intel Core i7-2630QM Mobile Quad Processor
-Intel HM65 Express Chipset +ICH10
-17.3" 1920x1080 120Hz Anti-Glare Matte Screen
-nVidia GeForce GTX 460m 1.5GB GDDR5 VRAM
-nVidia 3D Vision Active Shutter Glasses
-Creative EAX Advanced HD 5.0
-THX TruStudio
-8GB DDR3 1333MHz RAM (Max 32GB)
-2x500 Seagate Momentous XT Hybrid HDD
-Blu-Ray 4x Burner
-Logitech Performance MX Darkfield Laser Mice
-Microsoft Windows 7 Ultimate

-XBOX360, PS3, Wii

jorlanm wrote:
Can I use the ASUS RAZor mouse software with my Logitech Performance Mouse MX?


NO!
[SIGPIC]Kicking Ass Since Today[/SIGPIC]

damn...I kinda lke how GUI is for the ASUS...the Logitech is so plain...The buttons are like placed the same anyway...
-ASUS ROG G73SW-3DE-
-Intel Core i7-2630QM Mobile Quad Processor
-Intel HM65 Express Chipset +ICH10
-17.3" 1920x1080 120Hz Anti-Glare Matte Screen
-nVidia GeForce GTX 460m 1.5GB GDDR5 VRAM
-nVidia 3D Vision Active Shutter Glasses
-Creative EAX Advanced HD 5.0
-THX TruStudio
-8GB DDR3 1333MHz RAM (Max 32GB)
-2x500 Seagate Momentous XT Hybrid HDD
-Blu-Ray 4x Burner
-Logitech Performance MX Darkfield Laser Mice
-Microsoft Windows 7 Ultimate

-XBOX360, PS3, Wii

Lezz wrote:
Hm.. Maybe I've got something like this.... There were a number of BSODs "BUGCODE_USB_DRIVER" when only USB device plugged in was ASUS mouse which come came with G73jw-A1.



BigKenW,
any luck?
i've got full memory dump on this case... Going to contact them too..



Just a tiny update for those, who maybe running into the same issue:
1)Asus support was of no use..
2)BSODS are gone, after I've disabled "usb virtualization connector driver" in device manager. (Maybe this is not the actual reason, maybe there's something else)