Showing results for 
Search instead for 
Did you mean: 

ASUS G752VS: Windows 10 Installer Not Recognizing New M.2 SSD - [solved]

Level 7

I recently purchased a new laptop (ASUS G752vs) which has Windows 10 installed on the HDD. I bought and added the Intel 512GB 600p M.2 SSD to the machine.
I went into disk management and activated/formatted the drive and assigned it a letter. I now see the drive in "My PC".

Also if I run diskpart and run a list disk, the disk is there. So far so good.

However, when I launch the windows 10 installer from USB and go to select which drive I want to install windows 10 on, it only shows my HDD.
Tried Windows Support for a couple days now but no luck.
Is there something that I am currently missing? How do I get the new SSD to appear in the Windows 10 installer list?

Any help is much appreciated.


Level 10

Hey, yes I did, I don't think I missed anything.
I downloaded windows ISO and used the Windows 10 tool to set up the USB, as well as trying to use Rufus when the first attempt didn't work.

At boot, I selected UEFI: PNY USB 3.0 FD 1.00, Partition 1, to boot the Windows installer from USB.
Once I make it into the menu to select which drive I want to install on, my SSD is no where to be found.

My bios is version 306, so they're up to date. Is there something else I'm missing? I'll try anything this point haha

Noticed I hadn't tried loading the Intel Rapid Storage Technology driver during the Windows 10 installation.

I tried both 14.8 and 15.2 but neither time did my SSD show in the list. Anyone have any other things I could try? Running out haha

Level 7
You needed to get the driver from intel for the SSD during the step where the windows installer ask you if you had any additional drivers, otherwise you won't find it during drive selection! It's pain in the butt for me, it did took me 3 tries before it worked.

Sent from my iPhone using Tapatalk

Level 10
Please note also that not all irst drivers do not work. Same situation for me. Try several sources of the irst driver, or try the iRST in the esupport folder from your OS drive. I think that one also worked for my samsung 950 pro.

If you don't use raid mode, switch sata mode to AHCI (raid disabled) and that does not need iRST drivers anymore.

Just switched to AHCI and the SSD is now in the installer list!
I'll update after. Hopefully everything goes well, fingers crossed....

Switching to AHCI worked! That was the one thing I was missing.
Thank you very much to everyone who helped! I really appreciate people taking the time to drop some tips.

Edit: Deleted the last one since I wrote the confirmation in the title and it looked silly