cancel
Showing results for 
Search instead for 
Did you mean: 

Asus g74sx Blank/Black screen after Boot.(cant see logon screen,desktop.etc)

frozster
Level 7
Hi guys, so for the pass few days Ive been searching the forums and the web for a solution but failed so i figure its time to put it out there. Here's the scenario, upon booting up my g74sx, i am able to see everything up until after the windows 7 logo loading screen, then everything just goes blank. I cant see the logon screen, but i am able to login to the desktop. (could be heard) but the screen remains blank/black.

Funny thing is, i am currently typing on it right now ! using an external monitor through hdmi. I'll list down what ive tried and then my specs. hopefully some of you can give me a new lead before i decide to format my laptop.

symptoms:
-Black screen from windows logon screen onwards.
- Occasionally i can see lines on the screen/working properly for a brief moment when i watch a video through hdmi.
- It stated happen a week ago, after i gave it a cleaning session (blow out dust using datamax metro), not sure if this was the cause.

What i tried:
- Remove Nvidia driver (etc), and reinstall latest version (310 something) / the one that came with the laptop (268 something). Didn't work, still black screen. One thing to mention would be that , while running with the onboard graphic (without nvidia driver installed), the screen would work fine. i can see everything but resolution limited to 1280 x 1024).
- I have rollback rx installed, so i rolled back a few times, tot he previous known working snapshot as well as to the earliest snapshot ( after format and clean install of drivers) but it still didn't work.
- Tried to ' load default settings' for bios, and boot. but no luck.
- Booted into safe mode, working fine at low res onboard graphic.
- Tried lowest resolution setting 800x 600 didn't work.
- fn + f7, backlight is working but no image on screen.
- Booted into Ubuntu live disc, and it works like normal. i can use the full 1920 x 1080 resolution fine.:)

Spec:
Asus g74sx
Windows 7 ultimate.
Intel i7 2630qm
12gb Ram
1 x crucial 128gb ssd (c drive)
1 x 750gb hdd (d ,e drive)
nvidia 560m


Let me know if there's anything else that i could include. Many thanks.
420 Views
6 REPLIES 6

Pitcher1
Level 9
could you try reinstall OS or press F9 to restore OS?

I'm having the same issue. Any resolution?

had the same problem..... dont remember if my problem went away after updateing my video drivers...

I did try to update to the latest graphic drivers, still didn't work. Gonna try to uninstall the drivers, use driver sweep to delete all old drivers, and reinstall.

I uninstalled the driver, did a driver sweep, still does not work. One thing I notice is that when I first turn it on and it's supposed to load up with the initial boot screen, the screen looks fuzzy/broken lines. When it first loads and I press F8 to try and boot into safe mode, I'll see the letters for a brief second and the screen will shut off/turn black on the laptop.

However, if I connect to an external monitor, EVERYTHING works fine.

BIOS is up to date. Downloaded latest graphics driver.

This is all started when I left the laptop in the car and it was a HOT day. Possible MB damage?

We took apart the screen and it was a loose connection in the back. Maybe the heat caused the tape to wear off and the cable got loose from the screen, but now everything works.