cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS G73SW bad FPS drops playing League of Legends.

erikhell
Level 7
Hi,

I have spent allot of time these last weeks trying to sort my problem out. I get bad FPS drops playing league of legends. I installed throttlestopper tried diffrent graphics settings, I have done a complete reinstall on Windows and the game.

My FPS goes like 65 -> 125 -> 152 -> 9 -> 65

I have also noticed that my sounds is strange it works everywhere just fine but when playing LoL it sometimes echoes it can sound like this:

"Welcome to summoners-summoners-summoners-summoners-rift-rift-rift."

Anyone else who suffered from this issue and managed to get it working? I have uninstalled P4G or whatever that app was called.


This is so frustrating, hope someone out there can help me.. Spent so much time trying to fix it myself 😞


Best regards
/Erik
249 Views
29 REPLIES 29

I have now updated the drivers requested. LAN, WLAN, Sound.

But my chipset drivers still is Intel Chipset INF Update Utility 9.2.0.1015. not Intel Chipset INF Update Utility 9.2.0.1030. Think this might be the problem?

I have not updated that drivers since the test on intels webpage it says I do not need to update, shell I do it anyway? And if so im a bit nervous I will break something... What do you recommend?

fuzon1337
Level 10
Hmm, if fyou did find a later version for your notebook and the Update utility check didn't find a newer version for you, I would recommend to install the latest version for your notebook 🙂 If it is the wrong or not supported it would not be installed on your notebook 😉

Install and then do a reboot, if something goes wrong you could restore to an earlier point when it works as it should do 🙂

I'm currently useing a Galaxy Tab 10.1 and just have to remember which hardware and info is in that notebook, sine mine is at the workshop for some humble mumble issue (KB backlit def) -.-

EDIT: is there any noticeable difference after those updates you have done so far?
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205

Hi,

Well drivers are updated but sad enough it did not solve the problem. I have noticed under device manager "other devices" that I have:

Universal serial Bus (USB) controller that is not correctly installed.. Any idea what this is, can it be related to me FPS prob's?

fuzon1337
Level 10
I don't think that has anything to do with your FPS problems, that seems like a USB controller that is not correctly installed (to quote you), you could uninstall it and let microsoft find the driver for it, if you have the possibility to choose a option named "roll back driver" or something like that you could try that out 🙂

But this FPS loss syou get during games, does it only occur LoL or other games too?
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205

Hi yes there is diffrence, now when I set my videocard in game to benchmark i stay around 200+ fps it goes up and down. To my surprise i still get drops like 240 - 152 -190 - LAG - 5 - 152- 200, unfortunatly I dont have any other games. I installed the 3.0 usb under the link you sent me and it solved the uninstalled usb thingie..

This is so wierd.. I have tested diffrent Nvidia settings to, but I dont really understand tripple buffering and things like that but I followed a link at LoL's homepage and used those settings.

fuzon1337
Level 10
Okey, so I've searched on google and found this site about CPU Throttling issue with fix (or how the user in that forum fixed it) for LoL gamers, find the third last post and read that one 🙂
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205

Have already read it and tried it. It's not the issue, and I have throttlestop installed also. Gonna read more about it if there is any setting I have missed but I dont think so.

Icemanforlife
Level 9
Did you turn on throttlestop?

Yes its turned on. This is what my Throttlestop 4.0 settings look like please get back to me if you see anything that might be the cause of this. I have tried some diffrent settings also. I attached a picture.

fuzon1337
Level 10
I found a new site with possible solution, take a look at this site, if you not already have looked at this page.

EDIT: Btw, whcih battery configuration do you use, either in P4G or Microsofts own utility, high performance?
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205