cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS G73SW bad FPS drops playing League of Legends.

erikhell
Level 7
Hi,

I have spent allot of time these last weeks trying to sort my problem out. I get bad FPS drops playing league of legends. I installed throttlestopper tried diffrent graphics settings, I have done a complete reinstall on Windows and the game.

My FPS goes like 65 -> 125 -> 152 -> 9 -> 65

I have also noticed that my sounds is strange it works everywhere just fine but when playing LoL it sometimes echoes it can sound like this:

"Welcome to summoners-summoners-summoners-summoners-rift-rift-rift."

Anyone else who suffered from this issue and managed to get it working? I have uninstalled P4G or whatever that app was called.


This is so frustrating, hope someone out there can help me.. Spent so much time trying to fix it myself 😞


Best regards
/Erik
31,453 Views
29 REPLIES 29

fuzon1337
Level 10
You could try to install CCleaner and check your register and see if it finds some junk that you don't need.

Btw, which version of the nVidia driver do you have?
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205

I have tried diffrent drivers but now I use the latest beta driver 290.53.

I know many others have this issue with G73SW and LoL anyone of you have same computer and play it without problems?

I have also just reinstalled windows and hardly have any programs installed so cant be that much junk in register..

erikhell wrote:
I have tried diffrent drivers but now I use the latest beta driver 290.53.

I know many others have this issue with G73SW and LoL anyone of you have same computer and play it without problems?

I have also just reinstalled windows and hardly have any programs installed so cant be that much junk in register..


I have the same problem... And my computer gets to hot in the back (right side. graphic board)

fuzon1337
Level 10
Ok, hmm... Has it always been like that or is this a new issue you have experienced?

Perhaps you could use a older graphic driver to see if that fixes it 🙂
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205

I want to start with saying im so glad you are taking youre time to help me with this issue.

No this started around christmas after a patch update in the game. Since then its been more or less unplayable. FPS drops range often starts when graphics get a little bit more heavy around 2-4 mins into the game. I know many other SW users have this issue since I have read it on other forums. Thats why im curious if anyone have a ASUS G73SW and can run the game fine now, without and fps drops at all? If so I know its not my computer that is faulty but the game update.

Anyways since im not the best with computers im very glad for any ideas on how this can be fixed..

/Erik

erikhell wrote:
I want to start with saying im so glad you are taking youre time to help me with this issue.

No this started around christmas after a patch update in the game. Since then its been more or less unplayable. FPS drops range often starts when graphics get a little bit more heavy around 2-4 mins into the game. I know many other SW users have this issue since I have read it on other forums. Thats why im curious if anyone have a ASUS G73SW and can run the game fine now, without and fps drops at all? If so I know its not my computer that is faulty but the game update.

Anyways since im not the best with computers im very glad for any ideas on how this can be fixed..

/Erik


Ok have you tried running the game without the patch to see how your FPS are? if you have tried absolutely everything that has been suggested and nothing works, like you said....it's most definitely the update/patch. If the patch turns out to most definitely be the problem, then inform those in the Forums you have been asking in and just tell everyone to uninstall the patch, until the game makers can fix the problem. Stuff like this can and will happen from time to time.

fuzon1337
Level 10
No problem, I'm trying to learn a lot self when I help others either I'm wrong with something or right hehe 😛

Ok, so you're saying that you have done a complete installation of, your notebook, how is it with the latest drivers for your WiFi card, processor (and I don't need to ask about the graphics since you already have told that 😉 )

How about get rid of all the bloatware that you don't need?
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205

This could be intresting, so glad to get some new input.

How do I update drivers for my processor and Wifi and how do I know if I have the latest or not?

Can really Wifi drivers slow down FPS?

/Erik

fuzon1337
Level 10
If you got the Atheros card in you're notebook, there is a chance that can cause problems.

Take a look at JRd1st thread Drivers, Apps and How to's and install the Atheros driver from there 😉

You could check which version you got by right click on computer -> manage -> device manager -> then hit network and then you should be able to see which version of WiFi card you got and dubble clicking it you will find out which driver version you got (hit drivers)

For your processor the same progress, you could download HWinfo64 from the same thread as above, and read which processor version you got there and you can read fan speed, heat sensors and so on in it 😉

Downloading the drivers for your processor, go to www.intel.com hit the support, and you can use the driver utility check (that they have made) to check for new drivers that are compability with their site (if you know what I'm saying here :P) or you can do it manually and find the drivers by your self 🙂

EDIT: also you could check out this thread about CPU Throttling and see if that helps, but I'm not sure if that is your problem for bad FPS 😞
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205