cancel
Showing results for 
Search instead for 
Did you mean: 

Asus g73jh gets super slow, stuttering, laggy! Little help!

asustr
Level 7
Hello everyone,

This may be the first time I am posting here. And I have a problem. My 5 y/o laptop gets very slow, espcially when I try doing a couple of things at once. For example, I am trying to install AC4 at the moment while surfing web with Chrome, everything gets crazy, I can't browse between Chrome tabs without it not responding, stuttering like it is laggy. It does the same in games. I thougt it might be the hard drive which I changed 3 years ago, but girst decided to do a clean install of Windows again. It was fine for a while until now. There is no heating problem, cleaned it properly recently. Should I change the hard drive? And one more thing, I haven't been using winfows updates since some updates clash with the drivers or something and I get BSOD. But I have used it fine without the updates for a long time (like 5 years). I don't wanna deal with vBios update stuff. So, should I change the hard drive? This is not normal right? I should be able to play a video game and alt-tab to Chrome. This should be normal 🙂

Thanks in advance for any help.
3,477 Views
3 REPLIES 3

billyray520
Level 10
You need to do some diagnostic tests first, to figure out where to begin.

You can do hdd drive test to see if that is near failing for starters.

You can check the Windows logs for Applications and System to see if there are any errors being logged

You can check the Performance monitor to see what is taking up so much cpu

After going through all of that, get back with anything suspicious.
Asus Maximus V Extreme BIOS 1903, see specs above avatar.

Asus G73 jh A1 laptop, BIOS 213, vBIOS OD2, 8 GB Ram, 240 GB Intel SSD, 180 GB Intel SSD. Win 7 Pro. Purchased new from PowerNotebooks.com in May 2010.
(both have 1920X1080 hd screens, mine above, hers below )
Asus G73 Sw XR1 laptop 8 GB Ram, 160 GB Intel SSD, 80 GB Intel SSD. Purchased used >Ebay 1/10/13, Did clean install of Windows 7

thanks for the response. I reinstalled windows 7, the games now worki but as soon as I alt-tab or something like that and use Chrome for example it gets very slow and unresponsive.

I tested the hdd with seatools and no errors.

Dont know how to deal with Windows logs. too complicated..

How do you use the performance monitor?

Can it be Chrome using too much XPU and lagging not responding?

Thanks

Hello?