cancel
Showing results for 
Search instead for 
Did you mean: 

Asus G701VIK wont install new Windows version, stuck on 1703

tuxedo187
Level 7
I have an Asus ROG G701VIK gaming laptop (i7-7820HK, GTX 1080). I have a huge issue - the laptop is stuck on an old Windows 10 1703 version which i cannot upgrade. If i try to upgrade it via the Windows 10 Update Assistant the program completes itself and prompts for a restart, after restarting the laptop gets stuck on ROG logo. No matter how long i wait it stays on that logo screen. If i force power off and restart the laptop just boots to the 1703 version as if the update never happened. Same thing happens if i run a direct setup from Windows 10 image by selecting upgrade - after completing the laptop gets stuck on ROG logo. But the funny thing is that if i create a bootable Windows usb by using media creation tool and then run it from boot menu the laptop gets stuck on ROG logo. Basically the laptop refuses to install or even run a windows usb of any other Windows version other than the 1703. Generally i would have no problem, but PUBG for example will stutter like crazy due to outdated nvidia drivers (does not allow to install new DCH drivers). I have tried power cycling, the bios is on latest version, i have tried adding a second 512gb pcie ssd and raiding it to a total of 1TB, i have tried various BIOS settings to no avail. I have found some old threads with GL502, G752 users complaining of similar issues back when 1703 was released but i cant see a proper solution. What could be the problem?
764 Views
2 REPLIES 2

world
Moderator
Hey Tuxedo,

Yea, that's definitely an old version of windows 10! Have you tried doing a system file check?

In case you haven't, try following Microsoft's instructions: https://support.microsoft.com/en-us/topic/use-the-system-file-checker-tool-to-repair-missing-or-corr...

I know you mentioned the behavior continues with trying to boot from USB, etc. but it's worth a shot

Thank you for your help, however i have found a solution myself. As a last resort option i installed an older version of BIOS (version 305 instead of the newest 311) and guess what - the newest version of Windows installed without a hassle and now all the games are working great. So to anyone having a similar problem with a ROG laptop - try to DOWNGRADE BIOS.