cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS G55VW USB 3.0 issues

niciuffo
Level 7
I just bought a G55VW and the first thing I did was uninstall Windows 8 and put Windows 7 on it. I installed all the drivers needed, but the USB 3.0 ports were having problems saying "This device can perform faster". I tried uninstalling and resinstalling everything but the problem was still there. So I decided to reinstall Windows 7.
WHen the installation finished, I installed all the Windows Update updates and then the chipset drivers, restarted, and installed the USB 3.0 drivers, and restarted again.
Then I put my USB 3.0 drive in one port of the notebook, and ran a quick HDTune test. The speeds were right (250MB/s read, 150MB/s write). When I removed it and re-connected it, though, it said the same thing as above, and the speeds were USB 2.0.
I tried different ports and sometimes it was alright, but the majority of the times it worked at 2.0 speeds. The USB drive works just fine on my desktop.
I also tried different USB 3.0 drivers (the ones in ASUS website + the updated ones from Intel) with no luck.
Thanks in advance for any help.
17,828 Views
14 REPLIES 14

Clintlgm
Level 14
OK, first thing you need the intel USB 3.0 Drivers I think the latest is*** .251 the**** .235 will work good too. Before you uninstall the current drivers. Uninstall Asus Charger plus form Control Planel/programs and features. reboot. uninstall your current USB 3.0 Drivers from Device manager. Reboot, then install the your USB 3.0 Drivers again. Problem should be solved. If you need or want the Charger plus program reinstall it. My G75 will occasionally act up and I'll have to uninstall the Asus Charger Plus program to get everything back on track again. I just don't install it any longer. one other thought back this time last year when we were sorting this all out. It seems that sometimes it takes 2 reboots after uninstall of USB 3 drivers to get them to completely removed and the new ones to work.
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro

Clintlgm wrote:
OK, first thing you need the intel USB 3.0 Drivers I think the latest is*** .251 the**** .235 will work good too. Before you uninstall the current drivers. Uninstall Asus Charger plus form Control Planel/programs and features. reboot. uninstall your current USB 3.0 Drivers from Device manager. Reboot, then install the your USB 3.0 Drivers again. Problem should be solved. If you need or want the Charger plus program reinstall it. My G75 will occasionally act up and I'll have to uninstall the Asus Charger Plus program to get everything back on track again. I just don't install it any longer. one other thought back this time last year when we were sorting this all out. It seems that sometimes it takes 2 reboots after uninstall of USB 3 drivers to get them to completely removed and the new ones to work.

But I have a clean install of Windows 7, and after installing the USB 3.0 drivers and nothing else, it says This device can perform faster. I don't have any of the ASUS bloatware installed, just USB 3.0 drivers. I installed them, didn't work, rebooted, uninstalled, rebooted, uninstalled from device manager, rebooted, installed, rebooted twice, tried, didn't work. Tried to reboot again, didn't work still.

Does it do this on all 4 ports or only on the left side ports?
Did all four ports work full speed under Win 8?
Also USB 3.0 can be really picky about cables, have you tried different cables?

Have you installed the latest Chipset drivers?
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro

Clintlgm wrote:
Does it do this on all 4 ports or only on the left side ports?
Did all four ports work full speed under Win 8?
Also USB 3.0 can be really picky about cables, have you tried different cables?

Have you installed the latest Chipset drivers?

The left ports don't even work sometimes, while the right ones always work but with those problems.
I unfortunately didn't check if they worked under W8 😞
I'm not sure I even installed the chipset drivers. I guess I'll uninstall the USB 3 drivers and install the chipset ones.
The device I'm trying to connect is a USB flash drive, so no cables.

EDIT: Uninstalled USB 3.0 drivers, installed latest chipset drivers and USB 3.0 ones, rebooted, no luck. 😞

Unfortunately it sounds like you may have a hardware problem, you might PM cl-albert he may be able to help you out. He's pretty switched on with these notebooks.
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro

Pitcher1
Level 9
are you install usb 3.0 driver from asus support site by win 7 OS of G55VW model. when you use win 8 is no problem?

4
Pitcher@asus wrote:
are you install usb 3.0 driver from asus support site by win 7 OS of G55VW model. when you use win 8 is no problem?

I tried both the drivers on ASUS website and the updated ones on Intel website woth no luck. I unfortunately didn't try it on Windows 8.

niciuffo
Level 7
ibbi wrote:
On windows 8 you cannot install the Intel USB 3.0 driver as it is not needed. Windows 8 has the USB 3.0 Drivers built in

I would install Windows 8 but my school requires Qindows 7 to be installed since most of the software we're going to be using are not fully compatible with W8. Is there some kind of unofficial USB 3.0 drivers or something else that I could install?

Your choices are download from Asus Download, Download from Intel download for Win 7, Win 8 driver is native.
All of the available drivers work, your having a problem with your particular Notebook and Win 7 installation.
At this point it might be advisable to restore your Notebook to the factory condition and verify that your physical ports are indeed working.
If they are indeed working under Win 8, then they will work under Win 7. If they are not working under factory Condition Win 8 then you most likely have a hardware problem.
If your USB 3.0 ports do indeed work under Win 8, then you must have had some failure with your win 7 clean install? I would recommend that with the next Clean Install you turn off Auto Update until you get the latest chipset drivers, IRST drivers, USB 3.0 divers, Installed once these main drivers are installed then allow MS Update to update your system files.
Then before you install a lot of software you should toughly check out your notebook. Run Furmark to burn in test your GPU temps should not get much over 80C running 1080 and full screen 15 minute. Run a burn in test 100% load on your CPU and Ram what your looking for your CPU and RAM are error free and your CPU is not over heating under a full load. You can use Hwinfo64 to verify your temps and all your other hardware.
If you should be having hardware issues its best to find out right away before spending all that time configuring and installing a lot of software.
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro