cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS g46VW died?

Mystery-_-Man
Level 9
I recieved my ASUS G46VW from HIDevolution recently, and everything was working fine. I went to plug in my mouse, and it suddenly shut off (it was plugged in). I tried to turn it back on, but it showed no signs of powering. Is there anything I can do before I resort to sending it back? Any help would be greatly appreciated.
538 Views
12 REPLIES 12

rewben
Level 13
try to take out the mouse; unplug the laptop from the power source; remove the battery; and do a power discharge (by pressing on the power button for a while). put only the battery back in, and try turn the laptop on.

chrsplmr
Level 18
Did you call HIDevolution ?? How long have you had it ??

I thought I saw somewhere, I could be mistaken, that the G46 doesn't have a removable battery.

This may be helpful ??
http://rog.asus.com/forum/showthread.php?32835-Possibly-bricked-G46VW.c.

Pitcher1
Level 9
could you try unplug all device and remove power for a while then plug power, is it able to power on, if can, you are able to unistall instant on or USB charge+ utility try again, also you can change other mouse to try again.

Pitcher@asus wrote:
could you try unplug all device and remove power for a while then plug power, is it able to power on, if can, you are able to unistall instant on or USB charge+ utility try again, also you can change other mouse to try again.


That literally made no sense. But no, it cannot power on. I doubt there is a correlation between plugging the mouse in and the power supply failure.

Pitcher@asus wrote:
could you try unplug all device and remove power for a while then plug power, is it able to power on, if can, you are able to unistall instant on or USB charge+ utility try again, also you can change other mouse to try again.


That literally made no sense. But no, it cannot power on. I doubt there is a correlation between plugging the mouse in and the power supply failure.

EDIT: Sorry for the double post.

Mystery-_-Man wrote:
That literally made no sense. But no, it cannot power on. I doubt there is a correlation between plugging the mouse in and the power supply failure.

EDIT: Sorry for the double post.


Have you contact HIDevolution regarding the problem and what seems to be the cause of it and also what are the specification of your g46vw as i am planning to place an order for the g46vw too and am curious if its the cause of customization or anything else.

Mystery-_-Man wrote:
That literally made no sense. But no, it cannot power on. I doubt there is a correlation between plugging the mouse in and the power supply failure.
EDIT: Sorry for the double post.

MM-- I must respectfully disagree friend. It made perfect sense (and a real good 'setup' hint on first boot .. to avoid an issue later ..
did you notice the @Asus in his 'user name' ? he may know something or two we dont) just NO help in your situation.

If when you plug it in .. you get no light .. can you test the power supply for output or take it to a local shop to test ??
Shame to ship the whole thing if the issue is the brick.
I have seen 'instant on' and usb's (not specifically on the g46) reek all sorts of havoc .. and it certainly makes sense to me that
there could be an issue with 'usb charger+' causing a 'brick' problem with some usb devices left plug in. I thought it was a
good 'trouble shooting' thought. Just maybe not applicable in your case.imho
'We' all want what you want--that thing to work and do everything you ask of it for as long as you wish or you Upgrade.
Best of Luck.

trust7 wrote:
Have you contact HIDevolution regarding the problem and what seems to be the cause of it and also what are the specification of your g46vw as i am planning to place an order for the g46vw too and am curious if its the cause of customization or anything else.


I can honestly say that I have Never seen an issue with HIDevolution and from all I have read
they provide quality work and customer satisfaction.

rewben wrote:
hm.. sorry for the wrong way to try revive a g46. i keep forgetting how its battery was installed 😕

Very rare for you to forget anything, et, it happens. You are usually 99.99% SpotOn .. Cudos.
ummm .. What were we talking about again ???

chrsplmr wrote:

Very rare for you to forget anything, et, it happens. You are usually 99.99% SpotOn .. Cudos.
ummm .. What were we talking about again ???


it must be the long hours of work (excuses, excuses) lol!

Mystery-_-Man
Level 9
It does not have a removable battery. Also, I the battery indicator does not light up when I plug it in. HIDevolution is making me pay for shipping both ways to get it repaired (kinda expensive from Canada). I am thinking of returning and buying through NCIX, as they would probably be easier to deal with.