cancel
Showing results for 
Search instead for 
Did you mean: 

AC wireless card for G75VW??

Sadler13
Level 9
Does anyone know if there is an AC Wireless card out to upgrade to on my G75VW?
I have the Asus Router that supports AC but my G75 doesn't have the card.
I knew about this awhile back when I purchased the Router but was checking to see
if there is now one that can be put in my G75.

Please let me know if anyone does

_Thanks
G751JY-DH71|| G75VW || Intel Core i7-4710HQ (2.5GHz || NVIDIA GeForce GTX 980M 4GB || |NVIDIA GeForce GTX 670M 3GB || 1 TB 7200 rpm Hard Drive, 256 GB Solid-State Drive (PCIEG2) || Intel Core i7-4710HQ (2.5GHz
109,112 Views
62 REPLIES 62

Pandur
Level 10
I got the 7260 in my G55VW. Works like a charm. Make sure you download the latest drivers for both wifi and bluetooth from Intel. I've had some issues in the past with previous drivers.
Asus ROG G55VW:
CPU: i7 3630QM
GFX: Geforce GTX660M with 2GB ram
RAM: 2x8Gb 2133MHz Kingston HyperX Impact (surprisingly the G55VW uses the 2133 X.M.P. profile)
Storage: RAID0 with 2x 256Gb Crucial SSDs (both msata, one in a sata adapter)
OS: Windows 10 x64

Pandur wrote:
I got the 7260 in my G55VW. Works like a charm. Make sure you download the latest drivers for both wifi and bluetooth from Intel. I've had some issues in the past with previous drivers.


I had to tape pin 51 the furthest pin on the right side on the front of the card (label side) and next boot up bluetooth was showing in the tray.

My only next problem although very minor, how do you get the bluetooth to show up when pressing fn + f2 to toggle wifi or bluetooth?
Anyone know??

Also to my previous post I think my whole shutdown problem was due to the power button ribbon connecting the Power button to the MB. I bought one online plugged and went on like nothing. Damn asus service center was telling me I have to buy a whole new keyboard for it, them mfers

I also just installed the 7260, the 7260.HMWWB.R variant, and came across the dreaded nonfunctioning bluetooth. My system was upgraded to Windows 10 from Windows 7 before the hardware upgrade. With that my BT was already nonfunctional, so I did not uninstall the Atheros BT drivers before the 7260 upgrade.

After the upgrade, BT still didn't work, I uninstalled all the Atheros drivers. I even went into the registry file to remove references to the Atheros BT drivers. In all the rebooting I did, I noticed the little blue BT icon would appear in the System Tray and a minute later it would disappear. Other reboots, I tried opening it and it seemed to work but then disappear again.

Turns out it was the Asus Wireless Console 3 program causing it to disappear. After uninstalling it, my BT works just fine, except I still can't control it using fn+F2. Better than nothing.

Hope that helps someone else.