cancel
Showing results for 
Search instead for 
Did you mean: 

Z13 Keep getting into bios update screen right after window update completed.

JeeHh
Level 7
Have anyone encounter this problem on the Z13? Right after the window update completed and restart needed for the complete installation process. The next thing after reboot it went straight into bios update screen, press yes for the update and make the tablet unresponsive. Had to hard shut down by pressing power button. Next try, press no and boot into windows. The following week and another new updates available through window update, and same thing happen again. After restart it booted to bios update screen.
1,172 Views
7 REPLIES 7

cl-Albert
US Customer Loyalty Agent
If the bios update is not completing, it may keep trying to update the bios until it is successful.

I've noticed bios updates nowadays can be rather scary since they can progress slowly and the system can appear dead, but you sometimes just need to give the system more time to complete the bios update, so suggest waiting a bit longer if you have not already.

Otherwise, wondering if you need to ask repair to take a look, but assume you are hoping for other suggestions or solutions before going that route.
Was thinking you might also try manually updating to the latest bios version, but everything will probably go exactly the same, so you may just want to see if waiting longer will allow the bios to update successfully.

Feel free to disagree or request more feedback from others. Thanks.

cl-Albert@ROG wrote:
If the bios update is not completing, it may keep trying to update the bios until it is successful.

I've noticed bios updates nowadays can be rather scary since they can progress slowly and the system can appear dead, but you sometimes just need to give the system more time to complete the bios update, so suggest waiting a bit longer if you have not already.

Otherwise, wondering if you need to ask repair to take a look, but assume you are hoping for other suggestions or solutions before going that route.
Was thinking you might also try manually updating to the latest bios version, but everything will probably go exactly the same, so you may just want to see if waiting longer will allow the bios to update successfully.

Feel free to disagree or request more feedback from others. Thanks.


True about the bios update, which is scary once messed up it will brick the devices. "If it ain't broke, don't fix it", preferably to wait for more stable bios available before manually updating it. Same goes for future windows updates.

Regarding the bios update, is there any normal rough period of time for a complete installation (say more than several hours)?

cl-Albert
US Customer Loyalty Agent
JeeHh wrote:
True about the bios update, which is scary once messed up it will brick the devices. "If it ain't broke, don't fix it", preferably to wait for more stable bios available before manually updating it. Same goes for future windows updates.

Regarding the bios update, is there any normal rough period of time for a complete installation (say more than several hours)?


A bios update normally should not take more than 10 or 15 minutes, so should not take too long when it works.

Check the actual BIOS version if match with "system firmware" version from Windows device manager

This happened to me when I try to downgrade my BIOS this morning

BigJohnny
Level 13
What type of drive config are you running. This sounds like its not detecting something needed to boot. Is everything in BIOS set to default values as in no OC or weird stuff?

BigJohnny wrote:
What type of drive config are you running. This sounds like its not detecting something needed to boot. Is everything in BIOS set to default values as in no OC or weird stuff?


Everything in Bios is in default values, have yet to try out any tweaking or OC.

hardgrax
Level 7

Hello Guys I have Asus rog flow 13 from 2022 i have big problem with it evry time trying get in to windows boot they come to bios trying many time and some time it's boot fast and normal ,  i try also reinstall a new Windows but they don't show me the ssd driver for the old os do u think guys my sdd can be broken????