cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Z13 GZ301ZC - No Sign of Life (trying to power ON)

Skiwee
Level 7
Hello everyone.
Yesterday I was happily browsing the web and closed my Z13. When picking it up again in the evening and tried to turn it on, nothing happened. Found it odd as I didn't use it for that long. But put on the charger and went to bed.

The next morning when checking it I found no sign of life. No indication of charging or wanting to power up.

Tried holding the power button while unplugged for 40sec = nothing

when plugged in no response.

Plugging the power adapter into another USB-c powered device it charged fine.

Any tips would be greatly appreciated as next week I have to go on a business trip. (obviously would have been great to have on the trip)

UPDATES:
23-04-2022:: Requested RMA.
14-05-2022:: RMA is waiting on the delivery of replacement parts. Also lucky my business trip got postponed to after May *fingers-crossed I get it back by then.
21-05-2022:: Received; *Motherboard was replaced. *System was reinstalled.
969 Views
0 REPLIES 0