Showing results for 
Search instead for 
Did you mean: 

ROG Flow Z13 Not Charging

Level 9

Few days ago, I was turning on my laptop and it wouldn't turn on even with the adapter plugged in, on ASUS website I found this solution which is the Hard Rest, and it worked. Yesterday when I turn on the laptop, I notes that the battery is not charging, it stuck on 8% and it is empty because if I unplug the adapter cable it will turn off immediately.
I'm using the original adapter from Asus, and I did all the possible solution.
Fix 1: Check For Hardware Issues on My Asus app.
Fix 2: Check The Battery n My Asus app, no issue defected.
Fix 3: Check The AC Adapter on My Asus app, it detects a problem with it.
Fix 4: Update The Device Driver.
Fix 5: Power Cycle Your Asus Laptop with Hard Reset.
Fix 6: Run The Power Trouble shooter.
Fix 7: Run SFC Scan.
Fix 8: Reset The BIOS.
Fix 9: Reset windows.
I tried different adapter but with the same issue.
Unfortunately, the problem is not solved, I bought it on 22-Nov-2022 and I'm really disappointed with this laptop, I was using surface pro for years and I had no issue with it, specially I’m not using this device with heavy usage, only office and browsing, I got it because it looks cool. 😞
Any ideas how to fix this issue?


Level 7

I have exactly the same problem - hard reset totally messed up the computer. Now it's perma at 15% and if I unplug it it switches straight off. I also tried everything. Any answers from Asus support from your side?

They told me to send it to the service center  in my city, so I did on 1-10-2023 and until now I didn't receive it.

This is the last update from the service center:

Dear Customer,
Unfortunately, there is a delay in spare part delivery . We will update you once the unit is ready. 
Thats it, they didn't even mention which part is defective. 

Thanks for the quick response! I will get in touch with them then - I only got mine end of March this year but have moved since and don't have the receipt =/ Will try to get it serviced then. Thanks for the info, hope you get it back and in the best of conditions soon!

I registered mine on asus website when I purchased it, so they didn't  aske for the receipt, the warranty period will be in their system. 

I got mine on Dec 2022, so i thought its only the 2022 model issue.

Level 7

Most probably its motherboard issue. you have to send it to the service.

Level 9

Finally, a few days ago I received it after 27 days in the Asus service center, and they changed the battery.

Now I have another issue which is:

The first time that I turned it on after I received it didn't boot, only the black screen, the fan was on, and the keyboard light was on too.

So I held the power button to turn it off, then pressed it again and it worked. I did all Windows updates and all Armoury Crate updates too.

It worked for one day then the same issue happened again, so every time I had to turn it off then turn it back on again.

Now it's not working at all, I tried to turn it off and then turn it on, but it didn't work, tried the hard reset didn't work either.

So I think I have to send it back AGAIN to the service center and MAYBE wait for another month, so MAYBE they can fix it properly this time while my warranty is expiring.




Level 7

I have the same problem. I'll try to contact with de service center.

Level 7

Having the same issue with a 2022 z13 that was purchased in December 2022, seems there is a fair bit of online chatter around this.

Level 7

I have the exact problem today. Installed a few games from steam. Played the next day for 30mins in cool conditions. Turned off like usual. The time i turn on the next time, 

Keyboard lit up, but screen is blank.

Charging port LED is also blank when insert the USB C charging cable.

Tried 40sec power button hold but still blank.

Im kind of regretting buying this laptop after seeing a couple of similar problems