Showing results for 
Search instead for 
Did you mean: 

Need some help with SSD Install into G20CB

Level 7
I recently bought a Asus ROG G20CB with a 1070 card and thought I got a 1tb SSD but it came with a 1TB Sata 3. I then purchased a Samsung EVO 850 Pro 512SSD and I realized the drive didn't come with the mount bracket and data transfer cable. It came with 1 small cable for the SSD to the Mobo. Do I need to order a mounting bracket or is there one inside the case? I haven't opened it yet. I am getting ready to order a SSD to USB 3.1 cable from either Amazon/Newegg so I can migrate the data before I install the SSD. I just want to make sure I will have all I need before I attempt the install. I am aware that I will need to go into Win 10 and disable the Raid and have it load with ACHI drivers.

Thank you.

Level 7
Whilst not trying to barge in on another persons thread, I hope some shared knowledge will help us both out ....

Can anyone provide some generic (I know THAT term in the PC world doesn't exist), information or recommended guidelines of BIOS setup under the SATA / SSD side of the BIOS, and mine developed a nasty BSOD fault, and without any restore points in windows (10), didn't note down the original settings of BIOS on the ASUS G20CB ...

I've tried a few suggestions such most of yesterday, but to no avail ...

Can some kind soul give us newby's some advice on what how to 'define' / tell the PC, it should use the SSD as the first port of call, boot, and other drives to follow.

(My problem, was that I have 2 drives in the G20, SSD 200 gig, recovery / system drive , and a 2T Datadrive .. and for some damned reason, BSOD overnight, couldn't find the system drive, and after a bit of digging, setup at that time allowed me to enter the CMD prompt, and how ... how, I've no idea, the C and D drives [volumes] had been swapped over ... explaining why windows wasn't booting ... so after using DISKPAR to swap D to G (boot), then C to 😧 [DATA], finally G back to C [boot that had been re allocated to D 'overnight' for what ever reason!], then followed the command line with a xxxxxxx /fix xxxx /f :a something like that [I got the notes with me] ... rebooted and nothing ..... Now I can't get into the option in windows to get into CMD line, only the 'list of options pressing 1-9 keys , safe mode etc ... but none of those options now work or breathe more life into it..... I'm a bit stuck .... any advice? I've got screen shots of the BIOS settings on the phone, so will pull those down and provide links soon.... )

What I haven't tried yet (I've only looked at this issue through SW ... for now)

Used / Created a WINDOWS 10 USB recovery tool ...
Opened up the G20 (Ever) ..... DC the Data drive to (1) force a change, (2) provide the only option to boot from a drive with the system files on ...
actually found a manual to go through the options of what the setting are in the BIOS for the G20CB (can't find the printed manual, isn't in the box !!)

I'll eave it there for now, will check through the day though ... Cheers for any help you can provide us both ....


Level 10
User WelshWhoopee has many instructional videos on taking apart/modifying/upgrading the G20, search for them. You'll need a bracket adapter for 2.5" to 3.5" if you are looking to put the SSD in the HDD spot.

If you are going to switch from RAID to AHCI post-install, I've posted responses to others with links on how to do it. If you are doing a fresh install, make sure AHCI is turned on ahead of time.
Asus G20CB - Core i7 6700, Nvidia GTX980, 16GB Ram, 256GB SK Hynix SSD, 1TB Samsung SSD.