Showing results for 
Search instead for 
Did you mean: 

Help! Black Screen on G20CB after bios 2202 update!?

Level 7
Hello everyone, im new to the forums so lets start by introducing my self. Im Adis from Sweden, i have some pc repairs experience but im not a pro.

So couple days back i have seen a new (to me) update for Bios and started Asus program to update it, and in the middle process of updating Bios the pc suddenly restarted it self, i immediately know that was weird and guess what? It was as i expected that something went wrong.
Now the problem is that my ROG G20CB won’t boot and i have a black screen. The Graphic card, hdd, sdd, fans and led lamps are turning on normally.
(Unfortunately my warranty has expired 2-3 weeks ago 😞 )

The things i have tried were:
1- Moving the jack (CLRTC pins) to the left to try a soft reset the Bios and it didn't worked
2- Moving the jack to the left and taking out the battery for 10min and it didn't worked ether
3- I have repeated the same process 1 and 2 with the Hdmi cable on the MB internal graphics and i still had the same black screen
So do you guys have any suggestion what to do next? What are my other options?
I have swiped thru whole forum and didn't find anything that can help my problem.

Level 7
Any ideas people i'm desperate to find a solution for this.

Level 8
It happened to me before I just updated my drivers and it worked again

I've also updated to the latest bios... have you tried disconnecting the power bricks (and unplugging them)?

Best of luck to your troubleshooting.

On a side note...I wish the mobo would support an m.2 larger than 256gb.

yes i have and it still won't boot neither to bios nor it shows anything on screen still the same problem. :mad:

Level 7

I ran into the same issue. I was able to fix it by doing the following:

Unplug the cdrom and hard drive for now and any front USB ports and audio cables. You don't need them to get a POST from a motherboard...usually.

1. Remove CMOS battery and place jumpers on pins 2-3 to clear the bios. With the battery unplugged touch the negative and positive connections where the cmos battery plugs in. This is to better ground the motherboard. For some reason I had to touch those pins together for 10 minutes before the motherboard would drain enough power out of the compasitors to start figuring things out again. Now place the jumper back on 1-2 pins (normal) and still leave the negative and positive cmos battery connections touching for a couple minutes while you hold down the power button ensuring that NO power is left in motherboard. Once that's done just plug back in the cmos battery. My cmos battery was a two pin plug in style like you would find on a laptop motherboard so I just used a small flat head screw driver to connect the two pins for awhile. If you have a normal cmos battery CR2032 then just flip it over and place it back in the port to have the same effect that toughing the negative and positive connections has.

2. Now that you are sure the power has been removed from the motherboard and the cmos jumpers are back to normal. Plug back in the cmos battery and try booting up the computer using just the onboard HDMI port on the motherboard. Leave the pcie graphics card out for now. The less crap we have to deal with in troubleshooting the better. Leave the computer powered on for 5 MINUTES EVEN IF YOU DO NOT GET A DISPLAY YET. (In training impatient technicians they would give the computer 10 seconds before assuming it wasn't working and unplug the computer and start pushing buttons like monkeys). Be patient.

3. After 5 minutes or so if it doesn't seem like anything is happening power off the computer and wait a minute and power it back on again and wait another 5 minutes. If you still are not getting a display then I would try steps 1 again but this time leave it over night and try step 2 the next day again.

4. If by now your not getting a display and nothing is plugged into the motherboard except power-CPU- ram then I might try re-seating ram memory or trying another power supply. Basically were exhausting everything leaving just the motherboard as the issue. You could always try a graphics card in the pcie slot to see if you get something on the display since the onboard HDMI isn't giving you anything but that's grasping at straws now and it would seem like the motherboard bios got whacked. Not sure if there is a way to fix a wack bios on a motherboard but I did notice it looks like the bios chip is removable. Something to think about.

I was finally able to get my G20CB Asus ROG motherboard back alive by doing steps 1 and 2. It took a couple minutes for the screen to come back online after I drained the motherboard long enough.


Hello Mike,

I have tried step by step like you told me to. But still no luck. My only guess now is that my motherboard is bricked. Only thing for me now is to buy a new one. So should I buy the same one Asus Intel h170 express or some other one. Which are a good replacement for this one?

One more problem is that I have a full name of the motherboard h170-p/g20cb/dp_mb but can't find any shops where I can buy it in Sweden or abroad.