cancel
Showing results for 
Search instead for 
Did you mean: 

Bsod after G20 bios update

pablotech1
Level 7
Long story short, I have a G20 with Win8. Wanted to upgrade to Win10 but needed bios update from Asus. Downloaded it and rebooted with new bios .cap file and got bsod with clock_watchdog_timeout error message.

There was no way to get out of that screen so I hit power button to shut off pc. When I turned it back on, pc doesn't boot, at all. Usually when it turns on, fans run for about 1 second and computer boots up. Now when I turn it on, fans start and run non-stop but pc does nothing. No screens whatsoever.

Tried different methods to try and reset bios. Help power button for 30sec with power plug off, also opened up case and tried to reset CMOS by switching CTRLC connector and by taking CMOS battery out for a few minutes. Nothing.

I'm out of options. Any suggestions? Keep in mind I cannot access ANY menus, as pc simply won't boot up at all.

Sent from my SM-G928T using Tapatalk
3,317 Views
2 REPLIES 2

Eleiyas
Level 10
https://www.reviversoft.com/blog/2013/01/clock-watchdog-timeout/

Seeing as you cannot access your PC at all, even after having attempted a CMOS reset and a hard-reset, I would recommend getting in contact with your local ASUS support.

chilinmichael
Level 10
Yep, it's bricked. The way Asus has bios updates delivered to this PC (unchecked through Windows, unlike a Dell where it writes then applies after reboot) is dangerous and dated. Make sure when you send it in to note to ensure the Bios is fully updated before it's returned (they'll likely swap out the motherboard)
Asus G20CB - Core i7 6700, Nvidia GTX980, 16GB Ram, 256GB SK Hynix SSD, 1TB Samsung SSD.