cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG G20CB power issues after SSD Install

Eclectic_Orbit
Level 7

Hello! I'm a PC mod newbie with a few questions for anyone willing to help. I've been upgrading an old Asus ROG G20CD that I use solely as a CAD drafting rig, which it excels at. I upgraded the RAM to 32GB (2X - Samsung M471A2K43BB1-CPB 16GB DDR4-2133 SO-DIMM) and installed an M.2 SSD (SAMSUNG 980 SSD 250GB PCle 3.0x4, NVMe M.2 2280) for the the boot drive / operating system. Everything work better than I could hope for, screaming fast and worked perfectly, but then I tried to add another SSD with a SATA cable next to the CD drive (Kingston SQ500S37/480G 480GB Q500 SATA3 2.5 SSD) and now nothing will turn on, fans don't flinch, not even power to the USBs. Even with the new SSD unplugged there's no difference. I've carefully taken this thing apart about ten times now and I'm at a loss. I'm hoping it's most likely something silly but I don't know where to start. Any ideas would be very much appreciated! 

 

My questions are, has anybody experienced this and what did they do to solve it? Why would plugging in a power cable to an SSD effect the machine's ability to turn on? 

 

Thank you! 

 

I7-6700

32GB RAM

Nvidia GeForce GTX 1070

@Welsh_Whoopee  you seem like the person who knows the most on the internet about G20s! 

 

109 Views
1 REPLY 1

Antiparras
Level 7

That's a very odd behaviour. SSD installation shouldn't trigger that kind of issue unless, during installation, something was incorrectly plugged or any component has been moved/detached accidentally. 

Something you can try is to locate the battery plug (it's a small 4-cable white connector) and unplug it for about 10 minutes. Plug it back and see if it made any difference. 

I would also unplug the DVD drive and plug the SSD to that SATA, unless it's fundamental for you.