cancel
Showing results for 
Search instead for 
Did you mean: 

RPCS3 having problem with the latest drivers

CampofMusic
Level 7

Hello Asus, i have the rog ally for couples months, i been playing some of my ps3 games on rpcs3 emulator and for some reason one game especially having hard time running on your latest drivers, have a look please on Ratchet & Clank Future: A Crack in Time from this video:
https://www.youtube.com/watch?v=NR-eRcg6quc&t

this video clearly shows you that the game is running fine on the emulator no problem at all, this video is couples months old and now look at my emulator on my latest drivers in the rog ally device:

black boxblack box

 

black box on the right side, this clearly shows there is a problem with the latest drivers of the device, you can look at comments on the video that shows that people do have the same result, and this is 100% drivers issues as i tried to roll back to oldest build of the emulator and i have the same issue, i can confirmed that on Steam Deck running the same game there is no issues at all, please ASUS fix this issues because i know for a fact people do use emulators on this device and having this issue is annoying especially paying that amount for a product that having problem with drivers.

thanks.

In this video, we'll look at the performance of Ratchet & Clank Future: A Crack in Time (RPCS3) PS3 Emulation on the ROG Ally within its stock Windows 11 operating system. ------ CONTACT ME------ Twitter - https://twitter.com/MaliceMoist Discord - Malicespeedwagon ------SUPPORT THE CHANNEL------ ...
2,510 Views
0 REPLIES 0