Showing results for 
Search instead for 
Did you mean: 

Red Dead Redemption 2 not running on Ally.... Again?

Level 9

So I've seen a post regarding a similar issue already but this issue I think might be a driver related one. 

I've just bought and installed this game on my Asus laptop an Nvidia device. But the Ally kicks up an error that is not new, that happens when launching the game and the Rockstar Launcher stops and shows a "game already running" error, and the option to exit the game. I removed this error by deleting the RDR2 folder in My Documents. Running again causes a "driver cannot initialize" error. I've had another driver error when attempting launching the game outside of steam and the launcher using the install exe.

This seems like a driver problem, and I know that the game has been running on Ally in the past for people. So I'm wondering if anyone else now has this issue and if there is a fix, or whether it's known and being worked on. 



Didn’t work for me did u do anything else?

just done this fix :

"The fix is actually so easy and you DON'T have to do a system restore or clean reinstall of windows....  go to system, installed apps, then search for 'package compatibility opencl opengl vulkan' and uninstall it."

For now, this is a workaround. Although maybe Vulkan will work better in future and I hope that a driver will solve the issue. Still...

I made sure I had the latest Bios, 335, via My Asus app, or alternatively you can use Windows Update: and go to Advanced, Optional updates, and the Bios is there.

Then go to System/Apps/Installed Apps and find the opencl opengl vulkan app and uninstall it. Your game should now run and use the Direct X 12 API.

Worked for me anyway.

Thank you ! works for me too

It works for me, thank you so much! 🙏

Level 8

Hello there, it appears that you are experiencing a driver-related issue while attempting to run Red Dead Redemption 2 on your Asus laptop. The "game already running" message might be tough at times, but eliminating the RDR2 folder was the correct thing to do.

Now, the "driver cannot initialize" issue could be due to your graphics driver. Make sure your Nvidia drivers are up to current. A clean installation of the graphics drivers can occasionally resolve such situations.
Also, check to see whether the game has any pending updates. Developers frequently release updates to fix compatibility issues and enhance performance.
If the problem persists, you could visit the Rockstar support forums or contact their customer service. Other gamers may have faced similar problems, and there could be community-sourced solutions or official help available.

In any event, troubleshooting these kinds of issues can be rather trial and error. Best of luck, and perhaps you'll be able to play Red Dead Redemption 2 easily soon! 🤠🎮

That is good general advice, thanks....

But maybe you were unaware that this post is in the section relating to the Asus Ally handheld PC. It is an AMD device and relies on very specific updates. It seems something broke RDR2 in a recent update, and as the game has 2 graphics api options, Vulkan and Direct X12, the game seems to fail when running using Vulkan. It was figuring how to stop it trying to boot using this api that fixes the issue for now.