cancel
Showing results for 
Search instead for 
Did you mean: 

Embedded controller issues

rogantano
Level 7

So I recently upgraded to a larger SSD, updated everything and installed a bunch of games. Only problem is sometimes my controls stop working, for example, when I play Halo MCC my controls will stop working roughly every 30 or 40 seconds for about 3 seconds. I've enabled controllers in the steam and game settings, I've switched to gamepad mode and not desktop, I've switched to auto mode too and nothing has worked.

I don't know if it's related, but armory crate has an update (313 I believe) for the firmware that won't install and doesn't give me any error messages.

Does anyone have any idea what's going on? I've tried searching online and nothing has worked.

1,210 Views
2 REPLIES 2

BanditoB
Level 9

It’s only a minor possibility, but what SSD did you install?  If it’s not fully compatible, it may be running out of buffer space and slowing down writes to the drive, which might explain your controls not responding temporarily.  Just a thought. 

bradleg
Level 7

Seems to be a known issue with halo mcc and rog ally, have seen a few people post about it and I haven’t managed to find a solution myself. Some have suggested a patch for armoury crate is needed, so perhaps asus needs more people complaining.