cancel
Showing results for 
Search instead for 
Did you mean: 

Ally keeps shutting down

BuzzUK
Level 7

Hey guys,

Hope some one can help here. I've had my Ally for about 4 days now, been playing it alot and not had any problems. I turn it on today with a 70% charge, and after sitting on the windows desktop for a 1 minute, the fan speeds ramp up and the device turns off.

I've tried to restore from the Asus Cloud Restore in the BIOS, but when it's downloading the files the same thing happens, wurr of fans and a shutdown. Can anyone help me here and suggest something, or do you think i'll need to return it for a replacement?

 

Thanks in advance =]

2,870 Views
9 REPLIES 9

fahdriyami
Level 10

Does this happen even when the device is plugged into the charger?

And does it feel very hot to the touch if you put your hand on the back part?

Yeah it happens when plugged in, fully charged, unplugged as well. It doesn't even feel warm, never mind hot. I can't find anyone else online having the same issue as me, it's very weird.

Anbby_ROG
Customer Service Agent

Hi @BuzzUK ,


I would like to confirm with you whether you have already updated the BIOS to the latest version 323. If you have upgraded to BIOS 323, does the shutdown issue still occur? Did you have any software or games running before shutting down, or was the system in a standby state? Thank you.

Hey there,

Yes I have updated to bios 323 and the power offs are still happening. It powers off seemingly at random. It can happen when I'm installing a game through steam, idle on the desktop, while in a game etc. I've charged it overnight and tested this morning, and it powered off within 2 minutes of logging into windows with 100% charge. When I go to power it on it turns off before windows boots up. I've removed the back and reseated the battery also which didn't make a shred of difference.

Anbby_ROG
Customer Service Agent

Hi @BuzzUK ,

 

Due to the need for your personal information.
I have sent you a message, please check✉. Thank you

Hi I’ve got same problem with my rog ally

Sorry to hear that. I tried literally everything I could find, nothing worked. Contacted Asus support who advised to send it back. I returned it to my retailer that I purchased it from and they replaced it. Havent had any issues with the latest one so far, so its probably worth returning it for a replacement.

Duuzy
Level 7

I’ve find solution in my case I just have to off cpu boost and console is useable but dunno if it’s only in my case or for everyone idk if that supposed to do be like that or my ally is broken

I am having same issue. How to off the cpu boost?