Showing results for 
Search instead for 
Did you mean: 

X299 - NVMe drive not using x4 speeds

Level 7

Hey all,

I have an Asus Tuf X299 Mark 1 with an i9-10920X installed. I recently added a PCI-e 3.0 NVMe m.2 PCI-e x4 adapter to expand my NVMe storage. When I did, my main boot drive, located under a heatsink in the M.2_1(SOCKET3) primary port, is now running at PCI-e 3 x2 instead of x4. I also have the M.2_2(SOCKET3) port filled.

The M.2_2 socket and the PCI-e expansion card drives are both running at x4. It's just the M.2_1 socket that's running at x2. Shouldn't I have enough PCI-e lanes (44) to run everything at x4? I also have two SATA drives. I've tried moving the expansion card to all of the other available PCI-e slots. If I remove the expansion card, my boot drive returns to x4 speeds.


Asus Tuf X299 Mark 1

Intel i9-10920X

64GB DDR4 with all 8 slots populated.

RTX 4090 (PCIEX16_1)

Samsung 980 Pro (M.2_1Socket3) *** Running at x2 ***

Samsung 970 Evo (M.2_2Socket3) Running at x4

Samsung 990 Pro (Generic expansion card, M.2 NVME to PCIe 3.0 x4 Adapter, tried in every slot) Running at x4

2x10TB WD Gold HDDs plugged into SATA6G_1 and _2

Blu-Ray burner plugged into SATA6G_4

2x8TB External HDDs plugged into USB

Side note, I've thought about Asus HYPER M.2 X16 GEN 4 CARD expansion card as the motherboard has specific support for it.