cancel
Showing results for 
Search instead for 
Did you mean: 

Rampage VI Extreme Omega Serious Bios problem.

JuSiZ1
Level 10
I can,t figure out what is problem on newer than 3105 bioses.
Newer bioses only works with default settings. If i put example 2400mhz mem oc system stops qcode BD or only put XMP on stops BD. Systems working on 3105 bios without any problem.

Theres what i test this far:

What working is Bios 3105 with ME v.11.12.82.1838

Tested Bios 3201 , 3301, 3403 and 3501 works only default settings. if putting memory settings only example 2400mhz others auto/default stops qcode BD or if put only XMP on stops qcode BD. Those work on bios 3105.

Someone in win raid forum mod bios 3501 with newer uCode not working and mod bios 3501 with bios 3105 uCode Not working.

And of course tested with manual voltages/timings/everything.

My system main parts.
R6EO
i9-10940X
g.skill F4-3600C16Q-32GTZR
Evga 3080Ti FTW3
4,320 Views
10 REPLIES 10

cekeu
Level 12
It has happened in the past with the R6E. Stay with the working bios and forget about this "update" The most important thing is to be healthy.

cekeu wrote:
It has happened in the past with the R6E. Stay with the working bios and forget about this "update" The most important thing is to be healthy.


Thats right but no REBar support. This is annoing because over 700€ motherboard and basic things doesn't work. If anyone from ASUS can't fix this i think this is last asus motherboard to me. In first place, quality of this board not convincing me because when i bought this i got two DOA boards. third board what come from RMA was fully functional before this bios problem.

MarcioTB
Level 9
Strange, mine is working fine with last bios and 64 GB (8X8) Gskill 3600. I've updated all times that new bios was released and every time worked. I can't figure out what is the problem.

MarcioTB wrote:
Strange, mine is working fine with last bios and 64 GB (8X8) Gskill 3600. I've updated all times that new bios was released and every time worked. I can't figure out what is the problem.


What processor you have?

JuSiZ1 wrote:
What processor you have?


7920x

MarcioTB wrote:
7920x


I have this cpu I9 7920x also and Rampage Extreme Omega and the latest bios & Intel ME from asus website and no issues here ...did you perorm a clear cmos with power down (remove from outlet) ? of course this should be done after each bios upgrade
MB: ASUS RAMPAGE VI EXTREME-CPU: Intel Core i9-7920X Processor Extreme Edition 4.2 GHZ auto-CORSAIR Hydro Series H80i v2 Video: GEFORCE GTX 1070 Founders Edition. - G.SKILL 32GB 14-14-14-34
F4-3200C14Q-32GTZR- Seasonic PRIME Titanium 850 w-SSD: Samsung SSD 850 PRO 2TB x3 -SSD: Samsung 950 PRO M.2 512GB OS-Sound Blaster Z -Intel Ethernet Server Adapter I210 CASE:Cooler Master: HAF X MONITOR:IPS LED LG 27" 27UD69P 27 inch 4K 5 ms TV: LG OLED55C8P OS: Windows 10 x64 Pro up to date

BigJohnny
Level 13
Look in the Modded BIOS section.

restsugavan
Level 13
Cascade Lake X had some issues from security vulnerable report. It require recently microcode to fixing checking lastest @Tistou77 modded BIOS on MODDED BIOS section.
W11CANARY 26063.1 Core i9 7980XE 02007006 MCE ME 11.12.95.2499 R6E OFFICIAL BIOS 3801 SAMSUNG OG9 FW 1019.0 SSD 970 EVO PLUS 1 TB x 3 NVIDIA RTX 4090 GAME READY 551.61 64GB GSKILL DDR4 3200MHz JBL 9.1 Sound Bar DTS-X

restsugavan wrote:
Cascade Lake X had some issues from security vulnerable report. It require recently microcode to fixing checking lastest @Tistou77 modded BIOS on MODDED BIOS section.


Ok, i see those modded bios section but not found any modded OMEGA rebar bioses.