cancel
Showing results for 
Search instead for 
Did you mean: 

New Encore BIOS 0505 is out

Int8bldr
Level 12
https://www.asus.com/us/Motherboards/ROG-RAMPAGE-VI-EXTREME-encore/HelpDesk_Download/

Looks like they have improved stability. Maybe XMP memory issues are addressed.

from ASUS website:

"ROG RAMPAGE VI EXTREME ENCORE BIOS 0505
01. Improve system performance and stability
Before running the USB BIOS Flashback tool, please rename the BIOS file (R6EE.CAP) using BIOSRenamer"

Edit:
Checked the BIOS module content with UBU. It is the same as in 0504 (same EFI, OROMs for storage, network etc, and same CPU mCodes etc) - the only thing different is the ASUS Board specific BIOS code. that should hopefully address XMP.
1,634 Views
27 REPLIES 27

Hopper64
Level 15
Thanks for the heads up!!
MZ790A Bios 2002, GSkill F5-8000J3848H16GX2-TZRK, 13900KS, EKWB D5 TBE 300, Seasonic Prime TX-1600 ATX 3.0, Asus Strix 4090 w/ Optimus block, Phanteks Enthoo Elite, Asus Claymore 2, Asus Gladius 3, Asus XG349C, Samsung 990, Windows 11 Pro

CSN7
Level 7
Well funny part is, despite the statement of improved performance in the two bios versions after 401 performance is down by almost 200 pnts in cinebench for me.

10980xe 5GHz used to get up to 5050pnts now its more 4850 or 4870 at best... exact same settings. Also stability is slightly worse.

Rolling back to 401 always fixes this fortunately.

tistou77
Level 13
We would have to see if it is because of the bios itself or if it is because of the last microcode (difference between 0401 and 050x)

EDIT : for Cascade Lake-X, of course
Sorry for my english 😄


Case: Lian Li A77F
MB: Rampage VI Extreme Encore
CPU: i9 10980XE
RAM: G.Skill Trident Z RGB Royal 4x8Gb @4000 C16
GPU: EVGA RTX 2080ti XC Ultra
PSU: Seasonic Prime Ultra Titanium 1000W
OS: Intel Optane 905P PCIe
DATA: Samsung 980 Pro
SOUND: Asus Xonar Phoebus

Well this is the first bios for the encore board that lets me put the AI Overclock to XMP and it will boot with my 4266MHz ram in it. Every other bios i have had to set the memory to manual and down clock to 4200MHZ so maybe they have at least fixed the XMP profiles that so many others have had issues with.

Biozzz
Level 9
n/a

Hopper64
Level 15
Still boots to cpu q code 38 and stops, restarts normally into windows. Wish that was fixed. Only occurs with a cold power off boot.
MZ790A Bios 2002, GSkill F5-8000J3848H16GX2-TZRK, 13900KS, EKWB D5 TBE 300, Seasonic Prime TX-1600 ATX 3.0, Asus Strix 4090 w/ Optimus block, Phanteks Enthoo Elite, Asus Claymore 2, Asus Gladius 3, Asus XG349C, Samsung 990, Windows 11 Pro

Hopper64
Level 15
And secure erase doesn’t work for nvme drives with 0505.
MZ790A Bios 2002, GSkill F5-8000J3848H16GX2-TZRK, 13900KS, EKWB D5 TBE 300, Seasonic Prime TX-1600 ATX 3.0, Asus Strix 4090 w/ Optimus block, Phanteks Enthoo Elite, Asus Claymore 2, Asus Gladius 3, Asus XG349C, Samsung 990, Windows 11 Pro

Zbigniew
Level 9
I also have bios 505, like 504, reset at cold power off. Samsung b-die CL14 3200 do not want to work stable in XMP mode. In bios 401 not any of the above problems. As I wrote in my previous thread - bios series 5xx is also not for me. We are waiting for bios 06xx.
I am very glad that Asus-Engineers has not yet forgotten about us. But for now the work is going weakly ...
(After all, I think it's a great x299 board. Read reviews on amazon.de)
...........................................................................................................
Re-edit February 8, 2020
I completely cleared the bios 0401 settings, reset the motherboard and removed the battery on the motherboard for the night.
Then I set bios 0401 completely by default.
I migrated to version 0505.
The memories work correctly in XMP mode.
Unfortunately, enabling the ERP-ready S4 + S5 function causes the computer to start incorrectly.
After starting, a single reset occurs and then the computer properly loads bios and OS Win10.
I return to 0401.
Version 0505 (&0504) has an internal error. It is a pity that it does not work for me.
Blessed are those who have not seen ... And now they see.

I have cold boot issue too. Turn on computer, stops at Memory Detect, hold power button to turn off system, turn system back on, then forced into BIOS by pressing F1, discard changes and exit. After that it boots up fine.

Is that the same issue you have?

It is driving me crazy.

Zbigniew wrote:
I also have bios 505, like 504, reset at cold power off. Samsung b-die CL14 3200 do not want to work stable in XMP mode. In bios 401 not any of the above problems. As I wrote in my previous thread - bios series 5xx is also not for me. We are waiting for bios 06xx.
I am very glad that Asus-Engineers has not yet forgotten about us. But for now the work is going weakly ...
(After all, I think it's a great x299 board. Read reviews on amazon.de)
...........................................................................................................
Re-edit February 8, 2020
I completely cleared the bios 0401 settings, reset the motherboard and removed the battery on the motherboard for the night.
Then I set bios 0401 completely by default.
I migrated to version 0505.
The memories work correctly in XMP mode.
Unfortunately, enabling the ERP-ready S4 + S5 function causes the computer to start incorrectly.
After starting, a single reset occurs and then the computer properly loads bios and OS Win10.
I return to 0401.
Version 0505 (&0504) has an internal error. It is a pity that it does not work for me.