cancel
Showing results for 
Search instead for 
Did you mean: 

New driver and FW for aquantia 107

Hopper64
Level 14
On the Marvell site, looks like new FW and driver 109 and ....21 respectively. **https://www.marvell.com/support/downloads.html
MZ790A Bios 2002, GSkill F5-8000J3848H16GX2-TZRK, 13900KS, EKWB D5 TBE 300, Seasonic Prime TX-1600 ATX 3.0, Asus Strix 4090 w/ Optimus block, Phanteks Enthoo Elite, Asus Claymore 2, Asus Gladius 3, Asus XG349C, Samsung 990, Windows 11 Pro
37,827 Views
56 REPLIES 56

octomobiki
Level 7
Hello All, I have the MAXIMUS VI EXTREME, and no driver installer seems to be able to work on my computer. I've tried the one direct on the support page, as well as this thread. I see in my device manager that there is a "Network Controller" without a driver, but windows continously says that the drivers are not compatible when I try to install them.

Is there something I might be missing to make this work?

octomobiki wrote:
Hello All, I have the MAXIMUS VI EXTREME, and no driver installer seems to be able to work on my computer. I've tried the one direct on the support page, as well as this thread. I see in my device manager that there is a "Network Controller" without a driver, but windows continously says that the drivers are not compatible when I try to install them.

Is there something I might be missing to make this work?


not sure about maximus but if it has the AQC107 controller, this might work:

Station Driver has a moded 3.1.121 firmware install package that works for our Asus boards now. The Marvell d/l aborts on ASUS boards.

tation Driver has a moded 3.1.121 firmware install package installs Marvell-Aquantia-Firmware-Version-3.1.121 without patching the install files.

https://www.station-drivers.com/index.php/en/driverss/Drivers/Marvell/LAN/AQC-107-108-100--and--AQN-...
worked for me.

the drivers you can get from Marvell directly:

https://www.marvell.com/support/downloads.html

I just click on windows 10 64 bit n the left scroll list and then part number AQC107 in the right scroll list.

Int8bldr wrote:
not sure about maximus but if it has the AQC107 controller, this might work:

Station Driver has a moded 3.1.121 firmware install package that works for our Asus boards now. The Marvell d/l aborts on ASUS boards.

tation Driver has a moded 3.1.121 firmware install package installs Marvell-Aquantia-Firmware-Version-3.1.121 without patching the install files.

https://www.station-drivers.com/index.php/en/driverss/Drivers/Marvell/LAN/AQC-107-108-100--and--AQN-...
worked for me.

the drivers you can get from Marvell directly:

https://www.marvell.com/support/downloads.html

I just click on windows 10 64 bit n the left scroll list and then part number AQC107 in the right scroll list.


when I try to download the firmware from that website it says illegal download attempt :(.

Edit: I was able to make the download work by copying pasting the download link into the browser. However when I run the atlflashupdate, it says "No AQtion network adapter found"

I've also tried downloading the drivers from Marvell, they do not install (or rather, the computer doesn't recognize those drivers as being correct).

octomobiki wrote:
Hello All, I have the MAXIMUS VI EXTREME, and no driver installer seems to be able to work on my computer. I've tried the one direct on the support page, as well as this thread. I see in my device manager that there is a "Network Controller" without a driver, but windows continously says that the drivers are not compatible when I try to install them.

Is there something I might be missing to make this work?
octomobiki wrote:
when I try to download the firmware from that website it says illegal download attempt :(.

Edit: I was able to make the download work by copying pasting the download link into the browser. However when I run the atlflashupdate, it says "No AQtion network adapter found"

I've also tried downloading the drivers from Marvell, they do not install (or rather, the computer doesn't recognize those drivers as being correct).


Hi,

I wonder what got you on an Aquantia thread when you don't have any Aquantia devices built-in with your motherboard.

MoKiChU wrote:
Hi,

I wonder what got you on an Aquantia thread when you don't have any Aquantia devices built-in with your motherboard.

Anyway, you need these firmware/drivers for your ASUS ROG Maximus VI Extreme (Z87) motherboard :

[FIRMWARE] Intel ME (Z87)

[DRIVERS] Intel Chipset/MEI/SATA (6x/7x/8x/9x)

- Intel Chipset Drivers


- Intel MEI Drivers (Drivers Only) :

Drivers - 8x/9x


- Intel SATA AHCI-RAID Drivers (Drivers Only) :

Drivers - 8x/9x


[DRIVERS] ASMedia SATA

[DRIVERS] Intel Ethernet/WiFi/Bluetooth

- Intel Ethernet Drivers (Drivers Only) :

Drivers - I21x-V (1.0GbE)


[DRIVERS] Realtek Audio (MB | Intel 6x/7x/8x/9x/1xx)

You have an ASUS ROG Realtek motherboard, so :

You need Realtek High Definition Audio Drivers (HDA - ASUS ROG/TUF/PRIME DTS&RTK MB) from the first post of the thread.

Follow scrupulously your CLEANUP process then your INSTALL process, for the next drivers packages that I would release, you will can directly follow your UPDATE process.


Argh - that was my mistake:

ROG RAMPAGE VI EXTREME <--- that's the model I have, it's the rampage model, but alas, those drivers when I try to install them say they do not work because a newer version of the drivers are already installed. (but the device doesn't show up and I still have an undefined network controller in my device manager list)88720

restsugavan
Level 13
Due they are many Aquantia AQC107 models which ASUS and other OEM use for their boards.
Some firmware was design to fixing signal loss and abnormal situation of NICs chips.

Here is my solution.
88710

Use Aquantia old classic tool call "DIAG" for update lastest Marvell Aquantia firmware.
Step 1 : Rename lastest firmware as short as you can .(aka AQC10731121A.clx in picture above)
Step 2 : Flashing new firmware via DIAG like picture above.
After finish exit from administrative command window.
You will notice the Marvell Aquantia LED lamp from NIC PHY down and It loss from Device Manager.
Don't worry.

Step 3 : Re-install lastest Marvell Aquantia Driver as picture below.
88711

It almost done. Enjoy your new Aquantia AQC107 NIC PHY with New Firmware and Driver.
If you're not sure which firmware was your AQC107 NIC PHY used.
Use " DIAG " to verify it again.

88712

Everything is easy.
W11CANARY 26063.1 Core i9 7980XE 02007006 MCE ME 11.12.95.2499 R6E OFFICIAL BIOS 3801 SAMSUNG OG9 FW 1019.0 SSD 970 EVO PLUS 1 TB x 3 NVIDIA RTX 4090 GAME READY 551.61 64GB GSKILL DDR4 3200MHz JBL 9.1 Sound Bar DTS-X

octomobiki
Level 7
and just in case...88721

restsugavan
Level 13
You must do by my solution above mate.
W11CANARY 26063.1 Core i9 7980XE 02007006 MCE ME 11.12.95.2499 R6E OFFICIAL BIOS 3801 SAMSUNG OG9 FW 1019.0 SSD 970 EVO PLUS 1 TB x 3 NVIDIA RTX 4090 GAME READY 551.61 64GB GSKILL DDR4 3200MHz JBL 9.1 Sound Bar DTS-X

restsugavan wrote:
You must do by my solution above mate.


Hello, i have an asus xg-c100c and my connectivity drops when downloading games from steam.

I updated the card to the firmware 3.1.121 but i used the atlflashupdate. Is this DIAG better? Also where can i download it?

Thank you in advance

PanosXidis24
Level 11
Yeah with old method like the Restsugavan is the best method!!!!working 100%