Showing results for 
Search instead for 
Did you mean: 

Issue with microcode on 9820x

Level 9
I just bought a 9820x and I noticed that the BIOS shows the microcode is 00000000.
I previously had a 7900x and the microcode was shown correctly.
When Windows is booted, the correct microcode can be seen in aida64 and, thus far, the cpu is performing normally.



I’ve already tried clearing the CMOS and removing the battery.
Any help would be appreciated.

If this is a BIOS bug with the refreshed cpus, any chance of a fix anytime soon? Also, is there any likelihood that all recent microcodes are not fully compatible with the refreshed cpus?


Level 13
Reflash bios, maybe....
Sorry for my english 😄

Case: Lian Li A77F
MB: Rampage VI Extreme Encore
CPU: i9 10980XE
RAM: G.Skill Trident Z RGB Royal 4x8Gb @4000 C16
GPU: EVGA RTX 2080ti XC Ultra
PSU: Seasonic Prime Ultra Titanium 1000W
OS: Intel Optane 905P PCIe
DATA: Samsung 980 Pro
SOUND: Asus Xonar Phoebus

Level 9
I’ve already tried flashing the latest BIOS again, both original and latest microcode modded. I’ve started a topic on Intel’s forums here and thus far all responses are that it is an ASUS BIOS issue with the refreshed skylake-x cpus. Is anyone here using a 9820x or other 9XXXx model cpu with a similar issue?
Windows seems to properly detect the correct microcode, so it would seem it is related to the BIOS or ASUS’s implementation for support of the refreshed cpus.

Any further insight would be appreciated.