cancel
Showing results for 
Search instead for 
Did you mean: 

Intel Management Engine Interface Tool: Please check MEI Driver is installed.

Super_Gnome
Level 11

I have a Rampage VI Extreme Omega motherboard.  A few months ago my computer was running awfully slowly and I did not know why.  Then later I learned that there was a BIOS update.  I installed that no problem.  However, my computer did not seem to be running quite right after that, so I thought maybe another BIOS was in the works and instead switched over to using another computer.

 

Now a couple of months later I started this rig up again, only to see there was no new BIOS for it, only BIOS 3801 which I had installed a couple months ago.  But I also noticed there was an MEI update so I downloaded it, but then had a problem with it:  Getting the message:  Please check MEI Driver is installed.

 

I then found a driver that seemed to be needing installation and installed it from MokiChu:  https://rog-forum.asus.com/t5/downloads-for-motherboards/firmware-intel-me-x299/td-p/853149

 

After doing this I tried again to install with the MEI update tool, but continue to get that message:  Please check MEI Driver is installed.

 

At this point I am stumped about what to do.  I realize that I may have mistakenly installed the BIOS first, but do not know what to do now.  

 

Please help.

2,602 Views
20 REPLIES 20

Dragonfly79887
Level 11

It's hard to understand. Hope someone with more knowledge can help you

Honestly, I have had a heck of a lot of software related problems with this computer since day one.  That said, the motherboard page at Asus has confusing information.  With the download for MEI it reads: 

 

 "Intel has identified security issue that could potentially place impacted platform at risk.
Use ME Update tool to update your ME.
*We suggest you update ME Driver to the latest Version 11.12.94.2479 simultaneously.
Please download the file and check the MD5 code first."

Like how exactly do you update ME Driver to the latest Version 11.12.94.2479 simultaneously?

In typical Asus fashion you are left to wonder what this is all about.  Does this mean the driver is included?  If not, and you dont know, where exactly do you get this driver?  I thought Asus was supposed to supply you with this driver.  So is it included?  And why do you get this message?  And what does it mean?

 

Are all Asus customers expected to have university degrees in computer engineering or something?

 

It is very confusing.

 

 

 

Also what exactly is MD5 code?  And how do you "check" it?  Do you put a magnifying glass up to it?  Do you need to figure out what MD5 code even is?

 

It is all gobbledygook and may as well be in a foreign language from another planet.  Do all Asus customers understand this mumbo jumbo?  I mean I think the average person can build a computer but when it comes to Asus software, does Asus require you to have a university computer engineering degree?

Is your system okay, have you fixed it yet? If you haven't, please refer to the following articles: https://rog-forum.asus.com/t5/intel-700-600-series/intel-me-and-bios-updates-general-advice/td-p/913... I think it's possible to update: Intel ME driver New Intel ME firmware then go to BIOS (If the BIOS is already the latest, you don't need it anymore) After you read the above article, you will understand that if you want to update the BIOS, you need to have the corresponding Intel ME and Intel ME Drivers first. This means that if you want to update the BIOS, you will need to update the latest Intel ME Driver and Intel ME Firmware first. To get the latest Drivers and firmware, choose the correct Motherboard model in Mokichu's article: https://rog-forum.asus.com/t5/hardware-build-advice/index-all-my-drivers- firmware-software-threads/m-p/827232 In Bro Mokichu's article, there are full drivers and firmware. I think your problem can be fixed if you update DRIVER INTEL ME and FIRMWARE INTEL ME. Do you want to try ?

Thanks for the info.  Is it a problem if you downloaded and installed the BIOS before the corresponding Intel ME and Intel ME Drivers?  I did that not realizing it was important to do it the other way around. 

 

And if that is a problem what should I do now?

 

Also, before installing the latest BIOS a couple months ago I did a reinstall of Windows.  And before doing that I did not install any ME driver or anything like that, unaware that you should do that. 

 

Also, I am concerned that you might have to uninstall the old ME driver(s) first.  It seems to me you have to do that with AMD.

 

Lastly, in that article you posted about it says:  1) UPDATE ME WINDOWS DRIVERS
These are located on the DRIVERS & TOOLS tab under CHIPSET. 

 

I have no idea what this is about or where to find this stuff.  Is it in your device manager or something?  I feel like all of this stuff is so complicated I am lost.

In the end, I am very lost and confused by all of this.  The computer is just sitting on the shelf collecting dust, as is typical (honestly, I have had endless problems with updates, installs and a computer that seems to need a computer engineering degree to maintain).  It does not work correctly a lot of the time--being slow or running super hot or some other problem like updates not installing or something, and simple updates just seem like such a complicated, convoluted process for anyone but a computer engineer.

 

I have also reinstalled Windows dozens of times with this rig.  Things just never seem to work well, registry problems or this or that.  And I do not really use my computer for anything but a couple of games and simply internet searches, youtube, Netflix and that kind of thing.  Like, why does everything seem to be so darn complicated these days?  

 

 

 

 

In a nutshell, when trying to install MEUpdateTool, an error message occurs.  

This is the message:  Please check MEI Driver is installed.

79455.jpg

 

As for particulars, the motherboard is a Rampage VI Extreme Omega.  The latest BIOS has been installed, as has 11.12.94.2479, the MEI driver.

 

Thanks for any help with this issue.

 

 

 

In other words, does anyone know what to do if you get an error message when trying to run MEUpdate Tool?  

 

Dragonfly79887
Level 11

I see the latest bios of ROG RAMPAGE VI EXTREME OMEGA BIOS is 3801. To solve the problem you are facing try the following steps I think it will be fine - Clear CMOS (google please) - Reinstall windows - Install Ethernet driver - Active windows and update all the necessary things that the Windows version requires At this point, I think your device is fine. If it's not ok you need to check and install :- Intel Management Engine Interface V2120.100.0.1085(SW 2134.15.0.2422) For Windows 10/11 64-bit. Because you have already updated Windows, if when you install Intel ME 2134.15.0.2422 it says you are installing an older version, you do not need to install it because Windows has already installed the latest version for you. What about: Intel Chipset Driver V10.1.18836.8283 For Windows 10/11 64-bit. == > You definitely need to install it and of course if Windows says you're installing an older version, you don't need to install it because Windows has already installed the latest version for you. At this point, I think your computer will be fine because everything has been reinstalled from scratch. If done correctly, it will be as delicious and smooth as when you first bought it.

Immediately prior to installing the latest BIOS I reinstalled Windows.  So you think I should do that yet again, now, only a couple weeks later?

Also, I installed the latest version of the Intel Chipset Driver, which you are suppposed to "install simultaneously with the MEI driver," which according to the support page is how to do it.  Do you think I should instead now install an older one--which Asus does not recommend?

 

Honestly, I am just going to park this rig in the closet where it can continue to collect dust, much as it has done on and off since I built it because half the time the software doesnt work properly.  Asus software is as usual, garbage, unfinished crap that you hope works but doesn't.

Thanks all for your attempts to help.  As for Asus, I am never building a computer with Asus software in it again.  It has been an endless source of trouble for me.

 

thanks again.