cancel
Showing results for 
Search instead for 
Did you mean: 

Fried my R6E LED's?

GEEKCPA
Level 8
I just got my custom loop R6E back together, putting a new CMOS battery in it (required some splicing, soldering, and an external battery holder), replaced the two 1080Ti's with a single 3090Ti, upgraded the CPU to a 10980XE, refilled all the coolant, and turned it on. Everything was looking good until after a few hours the MB LED's went out, I heard a POP sound and smelled ozone. The lights in the GPU went out. I think the GPU LED's were 5V, but I mistakenly had them connected to a 12V cable (don't ask me how I did that).

It's likely I fried the 5V LED's, but would this also break the MB LED's? Is there a chance just replacing the armor plates and LED's fix this problem, or will I have to replace the whole MB?

Other than no LED lighting (CPU water block, fans and pump LED's all work) the system works fine. Anyone know of a source for a fair priced used R6E? I've googled and found some in China for over $1,200, which is ridiculous.
717 Views
5 REPLIES 5

cekeu
Level 12

I'm not certain my EKW water block would fit on the Encore or Omega boards. Plus, my boot drive is an Intel Optane SSD card in the PCIe 4X slot. The Omega's slot is not in the same location, and may not work. I'm probably stuck with a regular R6E. Wish I could find a NOS board, but if used boards are going for $1,000 to $1,200 what would a new one go for?

cekeu
Level 12
I see this refurbished ASUS RAMPAGE VI EXTRÊME: https://www.ebay.com/itm/125488241271?hash=item1d37ae9a77:g:D6IAAOSw-lhfI1hd&amdata=enc%3AAQAHAAAAsG... it looks serious the price a little more than half of the new card. But of course this is only a suggestion. You can use your card without leds but you liked it like that, it's true that it's one of the most beautiful luminous asus cards.
i have an ASUS RAMPAGE VI EXTRÊME ENCORE

cekeu wrote:
I see this refurbished ASUS RAMPAGE VI EXTRÊME: https://www.ebay.com/itm/125488241271?hash=item1d37ae9a77:g:D6IAAOSw-lhfI1hd&amdata=enc%3AAQAHAAAAsG... it looks serious the price a little more than half of the new card. But of course this is only a suggestion. You can use your card without leds but you liked it like that, it's true that it's one of the most beautiful luminous asus cards.
i have an ASUS RAMPAGE VI EXTRÊME ENCORE


Thanks for that link. I had searched on Ebay for R6E's and didn't see that one come up. I made an offer for one from a store in China, but the owner is away for another 10 days, so I'm not getting a response. I'm a little leery of buying from Poland, but I guess if it doesn't work out Ebay should make it right. (?) Poland couldn't be any scarier than China, right?

GEEKCPA
Level 8
Well, I plunked down almost $600 for the board in Poland
Crossed my fingers and hoped for the best. It got here pretty quick considering it went to China, then to Alaska, then to Kentucky, then back to Utah. Gave it the triple check, no bent pins, looked almost new. Changed the CMOS battery to an external holder, got all the tubing drained, reinstalled everything and turned it on. Everything works! I had to spend some serious coin to get this system running in it's current state. Granted, it's not as fast as my Z790 Hero with 13900KF and 4090, but it's in the upper 25% of current systems. There's something about a custom loop water cooled setup that just can't be beat.