Showing results for 
Search instead for 
Did you mean: 

Ethernet problem on X299-E GAMING

Level 7
I chose the Asus ROG STRIX X299-E Gaming for my new rig I built about 2 months ago. After the lego class she posted as expected. OS install, drivers, usual stuff but one thing I could not understand - the ethernet port was not working. Thought it's a driver fault, so I updated the chipset and LAN drivers to the latest. Still not working. Device manager - hard forcing it to recognize the port by deleting and scanning for hardware changes. No result. Clean OS re-imaging, installed only the chipset and LAN drivers (thought it could be a problem with the driver install sequence). Nope.

I gave up on fixing it and bought an Asus - XG-C100C network card to try to workaround my issue and it solved the problem. Now I was certain it is a defect hardware.

After a long month of researching, I only found one post on a random forum that XMP profiles might disable the ethernet port if enabled. I was sure I had not enabled XMP or turbo, nor did any overclocking ever since I built it (to make sure I have a stable system before losing any warranty with overclocking). My last hope was gone.

Is it really just a defect hardware issue? Have you guys heard anything like this before? Do you know what can cause this problem?
I've contacted the retailer, we agreed on them taking the board back. Before I do so, I thought I ask the community first.


Level 11
RMA the board it sounds like its faulty.

Level 7
Thank you for your advice, will do so. (Sorry for the late response, just got back home from a trip.)

Currently talking to the retailer. I'll post more info once I got a new one / it back.