Showing results for 
Search instead for 
Did you mean: 

Asus rampage vi extreme usb issues

Level 7

I have issues with some usb devices not working properly. It starten with Asus Rog Delta headset. The headset is used with usb c convertor to usb a. First the microphone stopped working (and red light was not on either) but the led and sound was working. Few days later the headset was not recognized by OS. Tried different ports with same result. The led lights are on even it is not found by the OS. Same issues with connecting external drive or usb, the power is on but not found by OS. I tried the same devices on my laptop and there was no issues at all. Mouse, keyboard and mousepad is working properlly on desktop.
I'm was on Windows 11 (uppgraded from Win 10) on the desktop and laptop. Changed the power settings on usb but same results. Updated BIOS to 3601, still same issues. I reinstalled the OS with Windows 11, same issues.
What could be the issue here? I don't know what else to try.