Showing results for 
Search instead for 
Did you mean: 

7900x never on turbo 4,5Ghz? [Fixed]

Level 7
I wonder why my cpu(7900x) on rampage VI extreme never goes to 4,5Ghz turbo. I always see max 4Ghz in taskmanager when running a simple application.
In the bios the cpu is running 4.0Ghz and saying turbo 4,5Ghz(defaults and stock clock).

Is something wrong or is intel turbo boost diffrent these days?

I remember my laptop with 4th gen i7 always running on turbo boost freq. and clocking down when thermal throttling. Doesn't happen with the 7900x one.

Can someone explain please? Thank you:)

also when benchmarking in CPU-Z:
when multithreading 4Ghz
when single thread still 4Ghz:confused:

This is what IXTU sees
I see there 45 ratio, but it never reach that in single thread

Level 11
4.5Ghz is only for the Intel turbo boost 3.0, you need to install the program to use that clock speed, your better off just overclocking your CPU to 4.5ghz.

I fixed it. I already had the intel turbo boost 3.0 application.

I had to change the bios clock from by core usage(default) to by specific core and the core ratios auto.

Then everything worked well!

Multi-threading uses now 4,3Ghz(turbo)
And single thread 4,5Ghz(3.0 turbo)

It works like it should:)

I hope I helped other with the same issues.:o