Showing results for 
Search instead for 
Did you mean: 

Z490-E Strix issue with Intel i225-V power management

Level 9
Every time I put this Z490-E to sleep, the network adapter never reconnects. Driver currently is version

Connected to a Cisco 9300 multigigabit interface at 2.5gb/sec with portfast enabled or a generic 1GB netgear same issue.

I have tried unplugging the patch cable and plugging it back in and nothing.

I tried updating to the latest Intel i225-v drivers, Version no change

I tried the complete updated armory, no change

I updating the firmware which is available on the ASUS drivers page to v1.45 and power cycled, no change

I cleared the entire computer, rebuilt from scratch, no change.

I can get the network to reattach after sleep is to open device manager, disable the adapter and re-enable it. This is quite annoying

Or, if I completely disable all power management from the network adapter, that works too but of course, this makes the adapter useless in a wake on lan scenario.

Has anyone encountered this sleep issue with the i225-v in their device and solved it?

Level 7
Had similar issue on Z490 Apex. Try unistall drivers, then reinstal Chipset and all drivers for Network.
Hope that helps!

Level 8
Just a faulty hardware, hope they start to implement the version3 on Z490 boards