cancel
Showing results for 
Search instead for 
Did you mean: 

Z370-F Gaming: Problem with extremely slow upload speed (Intel I219-V)

TheSwede86
Level 7
OS: Win 10 x64 Pro (Build 1803)
BIOS: 1601
Motherboard: Z370-F
NIC: Intel I219-V
Driver for above: 12.15.25.6 (2017-03-21)

Hello,

I have 1000/1000Mbit and when connecting with another computer (as my ISPs tech just did) I get around 900/900 where I get around 800/10.
It is ALWAYS the upload that is slow, never the download.

I DID NOT install any drivers at all from Asus after the fresh reinstall. Earlier I tried every single ethernet driver from Asus and also ran Intels update tool to get the latest drivers = Still slow upload.
I connect using a CAT6 ethernet cable (tried different cables = same problem) and when I boot into safe mode I get the speed I should get (i.e. around 800/800) and I even did a complete reset of Windows and got the desired speed after the reinstallation.

Sweet then it should be resolved right?
Oh no, nonononono.

I installed the following and did a speedtest after each to try and identify which application (if any) caused it:

* Nvidia Geforce Experience
* Battle.net and Heroes of the Storm
* Sophos Home Premium Antivirus
* Razer Synapse and Razer Cortex

However I did not reboot after each installation and even after uninstalling everything and rebooting I now get the same slow upload speed.

So its not hardware (my NIC or my cables) since it works in "safe mode" and after a complete reset.
My bet is either for some Windows Update happening in the background or a driver update that comes automatically.

Have anyone of you experienced the same?

Would be greatful for any help, going to reinstall again and check the driver it has during the very first initial boot and then reboot every time after I reinstalled something and check speedtest every time - TheSwede86

Edit:

Just reinstalled the OS again, the driver that seems to be there after the fresh install is:

Fresh initial boot (19-01-21):
OS Build: 1803 (1734.523)
Intel I219-V: 12.17.10.7 (2018-05-02)

However the ONLY applications I have installed are:
* Chrome
* Battle.net (and downloaded HotS)
and the build and driver above gave me around 853/945 but with no changes except above I now get 866/10.

Extremely wonky 😞
Any ideas?

Trying to install the "latest" (Version 12.17.10.7, 2018/07/25) ethernet drivers from Asus;
"AsusSetup.exe" does not even start and the "readme" is not exactly helpful or even applicable:
"
You can install Intel's Ethernet Universal Windows Drivers using the SetupBD.exe utility.
1) Download the latest Ethernet driver package and extract it to a temporary directory.
2) Copy all the files from \\Win32|Winx64\NDIS65\Universal to \\\NDIS65\. This will replace the standard drivers with the Universal Windows Drivers.
3) Run \APPS\SETUP\SETUPBD\Win32|Winx64\SetupBD.exe
"

Running the "Install.batch" gives me:
"
Please wait while installing drivers. Do not turn off or unplug the computer power during the installation...
Microsoft PnP Utility

Adding driver package: e1d65x64.inf
Driver package added successfully.
Published Name: oem41.inf
Driver package matches devices that already have their drivers up to date.

Total driver packages: 1
Added driver packages: 0
"

Update (again):

Intel® Network Adapter Driver for Windows® 10
Version: 23.5.1 Date: 12/14/2018
^ Installed above from Intel; no change.
6,712 Views
4 REPLIES 4

x-rated
Level 8
in my case device manager shows me driver version 12.18.8.4, so try to update to the latest version
+ increase transmit and receive buffers to 2048 via device manager

x-rated wrote:
in my case device manager shows me driver version 12.18.8.4, so try to update to the latest version
+ increase transmit and receive buffers to 2048 via device manager


Hi, thanks for your answer.

Just checked and I had the same driver version (12.18.8.4) as you now and I tried those settings (Receive Buffers from 512 > 2048 and Transmit Buffers from 512 > 2048 and it didn't do anything; Tested my speed again and I got 771/10.

x-rated
Level 8
so try another settings - speed & duplex 1 Gb/s full duplex

x-rated wrote:
so try another settings - speed & duplex 1 Gb/s full duplex


Speed & Duplex from "Auto-Negotiation" to "1.0 GBps Full Duplex" , no change.

Update:

Bought an Intel Gigabit PCIE NIC (using the Intel® 82574L Gigabit Ethernet Controller) and I STILL GET THE SAME THING.
Tried upping the Transmission and Receive Buffers from 512 to 2048 but did nothing I still get 10Mbit upload and 800Mbit down.

Update: Bought an external USB-C > Gigabit Ethernet adapter having a Realtek-chipset and it was the same.
Tried it on my work computer and got like 300/300.

Tried booting into Ubuntu and tried the built-in NIC and got consistent results of 800/800.
So something in Windows, something with either the OS or a driver from Intel.
Reset my BIOS-settings to "optimized defaults" but no change.

Edit:

I tried the default settings for the NIC and tested against speedtest (by Okta, their Windows 10-app) and also fast.com and there I get the the expected speed of around 900/900.
If I run "bredbandskollen"s CLI-tool I also get the expected speed so the problem only occurs when using their website.
I tried contacting them to bring this to their attention but received an automatic reply 😕

So everything is good, if another Swede reads this then try the CLI-Tool here:
http://www.bredbandskollen.se/om/mer-om-bbk/bredbandskollen-cli/
or another service such as either:
https://fast.com/ (press "Show more info" after the test to measure your upload-speed)
or
https://www.speedtest.net/sv