Showing results for 
Search instead for 
Did you mean: 

x299 i9-7900x slow responsivnes in windows explorer and other apps

Level 9
Hello and welcome,
I do have issue with speed of Windows 10 explorer (and other apps also, but less noticeable) on x299 platform.
I already posted (few months back) this question on MS tech forum but no one could give me solution for issue.

Link to MS tech forum, much more info then in this post, I keep this one minimal,

Windows explorer is slow when opening (and working afterwards) multiple instances, i.e. 10.
Video presenting issue, with strange behaviour depending on CPU load:

CPU at 0%

CPU at 60%

These videos presents Windows 1511 and 1703 and are recorded after fresh install on Samsung 850 Evo 256 GB SSD. Reason why I did this because my main system is Windows 1709 (Fall Creators Update) that's running on Samsung 860 Pro NVME drive exhibits exactly same behaviour. My other system (i7-4770 MSI GTX 970 on HDD) running same windows version works fine, very fast responsiveness.

I wanted to test if my hard / ssd drives maybe cause this issue, so I did disconnected all of them and kept only one SSD during tests - no correlation. Any correlation that I seen is CPU utilization. This was also reproduced on my main system (Windows 1709 FCU) when running CPU-Z benchmark with 18 threads and invoking | opening by "WinKey+E" explorer response much faster then without CPU-Z. Also CPUZ score is higher when using 18 threads instead of, all by default so in this case, 20 threads.


There is also an issue with slow responsiveness of other application, Open / Save file dialogue is slow, general window painting is also slow, not painting itself but there is a delay that gives an effect of that slowness, i.e. opening notepad++ and I see white window for a fraction of second and then all widgets gets painted. This happens under 1 sec mark but it's annoying.

Surprisingly other application like compilation on gcc / msvc / rendering with blender / cinebench etc. are performing within expected range / speed.

CPU: i9-7900X (stock)
Motherboards: Asus X299 Prime Deluxe BIOS: 1004 (1102 - is even slower overall, didn't tried newer BIOS then this one)
Memory: 32GB G.Skill 14CL
GPU: MSI GTX 1080 Ti
Drives: Samsung 960 Pro 2TB NVME (OS), Samsung 850 Evo 256GB (used on video for clean Windows install), Samsung 850 Pro 512GB, bunch of other drives unconnected during test.

What I tried on hardware level:
- replace GTX 1080Ti with GTX970 - same behaviour
- replace CPU with other i9-7900X with 1080Ti - same behaviour (my CPU went for deliding)
- RAM with or without XMP profiles - same behaviour

And here is kicker:
Linux Debian - no issues whatsoever.

Testing with OCCT causes error when testing using linpack or OCCT small data set (at random). When using linpack with 90% memory it passes 1h tests (same for both i9 CPU units). RAM testing is pending will do this probably today or tomorrow. Prime95 / compilation on both windows and linux / cinebench / aida64 practically any other stress test or demanding task passes without BSODS / crashes etc. and output (i.e. application) is correct.

At this point I'm out of idea why this happens any suggestions are more then welcome.

PS: I also tried:
- Windows power profile "High performance" / "Balanced" - same behaviour
- CPU don't thermal throttle, hits in OCCT 92*C tops, same readings from hwinfo while running prime95

PS2: Question / request for i9-7900X ASUS x299 Prime Deluxe (and other mobos) owners:
Can You runs this batch file (select and save as *.bat and run) and share Your results, does it instantly pops up all these new windows (I want to be sure that this is not "platforms feature")

set DPATH=%UserProfile%\Desktop

FOR /L %%i IN (0,1,10) DO (
call %SystemRoot%\explorer.exe %DPATH%


Took me 2days to figure out how to get this score, I am quite certain I know how I did... Now to get my USB 3.1 running 300% quicker then I think my OC adventure is nearly complete or atleast I am gunna stop tinkering and going 2 steps forward and 5 steps back
Hope someone doesnt tell me it is a false reading.


Level 9
Took me 15 min to perform these benchmarks to get around 600% increase:

Original performance:


L1 cache enabled:


So what's point of Your post? How this is related to issue described in this post?

BTW. good luck with this, You will need it :). As long as You do anything remotely "important" aka. non Facebook / web-browsing / gaming kind of thing without UPS it's basically useless and dangerous.

I have the same exact problem as the OP and almost the same exact setup besides the motherboard (I have a Asus Rampage VI extreme). Opening up windows explorer takes forever. My previous rig had a 4790K and it was 10x snappier than my 7900X rig. I thought it had to do with boost clock ramping, but that was just a educated guess. I'm wondering if I just overclock my rig to 4ghz (all cores all the time) if it will alleviate my issue (at the costs of power consumption).

I do know Microsoft has done some work here recently on their scheduler, mostly on the AMD side to support the new Zen 3 processors, but it would seem Intel engineers skimped out on optimizing Intel's big CPU's, because my rig has only gotten slower since the Meltdown and Spectre bug plugs.

Level 8

I have fixed my problem by using PowerShell terminal.