cancel
Showing results for 
Search instead for 
Did you mean: 

rogarena redeem points page doesn't work

QuantumAdaptati
Level 7
I just registered my 10 asus products I've purchased the last 2 years in hope to get reward points.

but when I click on the link on the page
https://rog.asus.com/us/elite
It sends me to
https://rogarena.com/redeem-points/

which returns 404.

also the old page,
https://rogarena.com/rewards/qualifying-product-purchase/
is gone.

has the registration for rewards program ended?
7,595 Views
6 REPLIES 6

QuantumAdaptati
Level 7
can we please get a confirmation that this program is dead?

xeromist
Moderator
FWIW, this is a customer discussion forum so it's unlikely you'll get a response from ASUS. There are a few employees that post here but I don't know if any of them are involved in the rewards program.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

xeromist wrote:
FWIW, this is a customer discussion forum so it's unlikely you'll get a response from ASUS. There are a few employees that post here but I don't know if any of them are involved in the rewards program.

Let's assume the site is not dead yet.I am still logged into the new site but,I cant seem to get the avatar/profile picture to update yet,still greyed out...

AgentHunk wrote:
Let's assume the site is not dead yet.I am still logged into the new site but,I cant seem to get the avatar/profile picture to update yet,still greyed out...


Oh, I'm not saying anything is dead. From the very beginning of this forum years ago it has always been for customer discussion. The presence of actual ASUS employees has always been minimal.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

AgentHunk
Level 8
agreed....I think this new site they are making it to be is still buggy and crappy...

under profile and my name it says NAN........

wtf.....

AgentHunk
Level 8
yeah,I am back to confirm and say that there is something wrong with the rog elite rewards site...it isnt loading or saying error page has been removed or whatever...