cancel
Showing results for 
Search instead for 
Did you mean: 

PC Turns On But No Display

thedarklord137
Level 7
Hi Everyone,
The other day I turned on my computer after a shutdown the night before and it would turn on but with no display although the fans and lights worked. After some looking around I found it was most likely a memory error due to the yellow/orange light showing up and some error codes such as 50 and 7F appearing. Then the code switches to 00. My question is, is this a memory problem and can memory fail just like this. My memory is not overclocked although my CPU was. I have tried reconnecting the motherboard wires and even using just one stick of RAM. I have also disconnected my GPU, USB devices and such. I have tried running it in LN2 mode but the fans run at what I presume 100% and the error code just shows 00 again. I have also tried running memok but it says that my memory does not work and my CPU has failed it's tests. I am also pretty sure it is not the PSU. My hardware is as follows:
6700k CPU overclocked to 4.5 through easytune in the bios
2133 skyhinks? Memory that came from a prebuilt before
Msi 1060 6gb gaming x
Asus Maximums Hero Alpha VIII
Samsung SSD 860 500 gb
590 Views
3 REPLIES 3

Arne_Saknussemm
Level 40

thedarklord137
Level 7
Yes I took out the cmos battery for about 15 minutes. When it was out and the PC unplugged I also hit the power button to drain the system.

Arne_Saknussemm
Level 40
If you have another PSU to test I'd try that and maybe test the CPU in a friendly store...?