Showing results for 
Search instead for 
Did you mean: 

Nvme drive and long (cold) boot times

Level 7
I had this problem before and I can't remember how I fixed it.
Bios doesn't recognize ("see") my nvme drive samsung 970 evo 256gb (232), but apart from that it's working seemingly without issues, except for the long ass boot times, obviously.

Motherboard: Crosshair VII hero (bios 2801 - the latest, reinstalled it just earlier today coming from the 2703 trying to fix this issue).
windows 10, also fresh reinstall (today -- and I secure erased that very drive, so even the bios itself can 'do stuff' to it, even when it doesn't display it anywhere else), so don't even start saying hardware issues or failing drive, I do remember this was often erroneously brought up, from when I fixed this very problem before. I can see the drive in windows disk management, I can see it in gparted (dual boot), I can do stuff with it and I'm posting from an OS freshly installed to it. Also checked firmware which was already up-to-date. I also already learned that some options related to nvme management were removed from newer bioses, but I can't see it listed even among the installed/available drives when I bring up the bios normie mode (ez), for instance -- and if my memory doesn't fail this was the main sympton of my problems (long boot times). CSM, fast boot, secure boot, I've always had them all disabled, and triple checked it all trying to address this.

Which reminds me that searching for this, I came upon the advice to erase secure boot keys. And I kinda messed up (or not, it removed older entries from the boot menu, which where kinda annoying me anyway), but now I can't bring up the boot options (f8) for this very fresh windows install, and I think this is also related to the fact that the bios can't see the nvme drive (i.e, it doesn't register/save the new secure boot key (yes, I enabled it once trying to verify this, it's already disabled again). Thankfully I did my dual boot correctly and I only start ubuntu from that menu, which otherwise defaults to an windows auto-start.

bios doesn't see my nvme ssd
problem: long boot times


Stuff like your dealing with either send you insane or give you a smirk a few days latter after you sure it has gone.

Hopeful we get somewhere with this soon (away from insanity) !

Yes, this all very frustrating indeed.
Finished last "night" off with a tall glass serving of brazilian schnaps -- they're meant for shots.

starting today, I think I covered all power options from within windows already. Gave up on most recommendations I was reading, which were leading me to have a idiotic power plan, WITH hibernate and fast boot turned on. I'm back on a (windows) high perf plan, hibernate off, and the other custom options I don't believe matter much anyway.

Now i'm focusing more on services, and i believe it was very easy and quick to dismiss any shenanigans coming from them.


That was a normal startup, with everything disabled, and right after that I performed a diagnostics startup, which I am sure took even longer.

I'll go back to investigate bios options, because even though the event viewer for boot degradation is filling up way above the norm, I'm wondering if the problem isn't on a layer below windows. My ubuntu boot is perfectly normal btw. Yes, those are contradictory statements. Yeah, I know, f*ck this sh*t.
(edit: it wasn't that bad, actually. 81 listed events. Considering I restarted, rebooted several times since my last review of this, which was on 60 events, I don't believe it's that bad. Especially on a system with very obvious loading problems, I mean, that's precisely why I'm here after all...)

here's the drive in which the OS is installed.
Fresh benchmark, from the samsung magician app.
Just for comparison's sake.

Everything thus far:
- A fresh windows 10 install (Windows 10 Pro, Version 1903, Installed on 10/01/2019 (october 1st), OS build 18362.387)
bios rolled back to 2501
- all drivers dodeca checked as new, and or best (using snappy driver software)
and I always ran a lean startup, I do use AI Suite for the fan controls though (ez update service killed off with 'autoruns', because f*ck that piece of crap). Apart from that, which I agree agree is kinda bloaty, I usually don't have steam/gog and stuff like that on auto startup. Anyway, They're not even reinstalled yet.
- Cold boots were fixed for a short period, don't know how or exactly why they reversed (I know when though, right after I reapplied my OC, but even rolling back optimized defaults and then clearing cmos, it remained bad)
- restarts and shutdowns always problematic throughout this entire ordeal, restarts at the 1m20s or thereabouts, shutdown+post+loading around 3 minutes
- last week all of this was still sub 10 seconds

gonna try to edit this post, been having captcha issues, which by seeing the thread about it (to which I also wasn't able to reply) I'm assuming it's not just me.
anyway I fixed the issue:
fixed it
downloaded and installed the windows boot performance analyzer and there I could find that volsnap (vss- volume shadow copy) and acpi were taking substancial pre-init times.
Then, redoing the msslldp security permissions portions of that guide resolved the issue.

Debian linux is working amazingly fast and flowlessly, But after I install Ubuntu based distribution (mint linux)

I can feel my motherboard ruined, slow and trouble.

When I was install ubuntu, it asked me to make insecure boot enabled, after that it ruined all my firmware, that is not recovered by bios flashing.

After that ruinning, PC runs well only with ubuntu

madamaou wrote:
Cleared CMOS and now cold boots are fine. Windows logo, or spinning circle, doesn't even show up, straight into the user splash screen.
But restarts are still atrocious (along with shutdown time).
Tested 3 times in a row, each.

edit: rebooting from ubuntu into windows is also almost instant. Felt Like switching channels.

Debian linux is working amazingly fast and flowlessly, But after I install Ubuntu based dstribution (mint linux)

I can feel my motherboard ruined, slow and trouble.

When I was install ubuntu, it asked me to make insecure boot enabled, after that it ruined all my firmware, that is not recovered by bios flashing.

madamaou wrote:
RedSector73, thank you; I appreciate your help.

But it didn't work. Just about to finish the newest reinstall and I'm still facing long boot times.
I took your recommendations very carefully, especially saving the secure boot keys in between the installation reboots, which was news to me, never heard of that one before (I think, probably). And I even removed my bd-drive from sata6_g1-2 just to be extra sure it wasn't even in the same namesake grouping (as I believe that it's technically sata_2 port). And also, reluctantly removed the other drives, which I didn't usually do but I already knew it was considered at least best practices, and on that topic, I even used the back panel 3.1 usb ports instead of my go-to trusty and very conveniently located ol' hub and I also didn't forget to load optimized defaults and not install it on an OC'ed system. All of this stuff, which I got away with before without a single issue.

Anyway now I think there are two possible culprits, first I think the boot times increased even more right after I installed the newest nvme driver from samsung, but i'm not too sure of that one, and second, I'll go find a way to delete old bootable mounting point entries, or whatever those are called. I first thought they were tied to the secure boot keys but that's not the case apparently.

I'll go finish up forgotten driver installations, already did the main ones, programs and tweaks, like moving user folders, symlink chrome and win temps, etc.

ps I also rolled back to bios 2501, it's much friendlier towards older ryzens.


Now the cold boot is actually manageable, I don't think I shut it down after the latest reinstall. Did it for testing. 29 seconds for the cold boot (after the post (beep)) but above one minute (~1'27") for restarts (again, after the post beep, discounting the shutdown times which are also unusually high). I'm (was :() used to sub 10" to a workable desktop after the post.

Level 13
Honestly 29 seconds really inst unreasonable. Hows it performing after boot?
My X299 on an intel 905P takes probably 20 seconds. Id say leave it alone and let it do its thing. Get the updates and let her rip. I always seem to shave a few seconds a few days after a fresh install. Not like a laptop. A lot of things going on between the power switch and getting to desk top. How long does it take to get past the ASUS logo screen? Dont start your windows boot timer until you see the dots going in a circle. Before that its BIOS initialization. Hate to see you chasing the wrong thing or nothing at all.