Showing results for 
Search instead for 
Did you mean: 

Nvme drive and long (cold) boot times

Level 7
I had this problem before and I can't remember how I fixed it.
Bios doesn't recognize ("see") my nvme drive samsung 970 evo 256gb (232), but apart from that it's working seemingly without issues, except for the long ass boot times, obviously.

Motherboard: Crosshair VII hero (bios 2801 - the latest, reinstalled it just earlier today coming from the 2703 trying to fix this issue).
windows 10, also fresh reinstall (today -- and I secure erased that very drive, so even the bios itself can 'do stuff' to it, even when it doesn't display it anywhere else), so don't even start saying hardware issues or failing drive, I do remember this was often erroneously brought up, from when I fixed this very problem before. I can see the drive in windows disk management, I can see it in gparted (dual boot), I can do stuff with it and I'm posting from an OS freshly installed to it. Also checked firmware which was already up-to-date. I also already learned that some options related to nvme management were removed from newer bioses, but I can't see it listed even among the installed/available drives when I bring up the bios normie mode (ez), for instance -- and if my memory doesn't fail this was the main sympton of my problems (long boot times). CSM, fast boot, secure boot, I've always had them all disabled, and triple checked it all trying to address this.

Which reminds me that searching for this, I came upon the advice to erase secure boot keys. And I kinda messed up (or not, it removed older entries from the boot menu, which where kinda annoying me anyway), but now I can't bring up the boot options (f8) for this very fresh windows install, and I think this is also related to the fact that the bios can't see the nvme drive (i.e, it doesn't register/save the new secure boot key (yes, I enabled it once trying to verify this, it's already disabled again). Thankfully I did my dual boot correctly and I only start ubuntu from that menu, which otherwise defaults to an windows auto-start.

bios doesn't see my nvme ssd
problem: long boot times


Level 7
inb4: so if you fixed it before how come you don'tapply the same fixes?
answer: too many concussions (as if I'd remember any of that). And my google-fu isn't the same anymore. Certainly age related. I'll even bet google has search results tailored for distinct age groups, and they're very mean to those above 35.

Here is the procedure for install of windows on nvme drive.

1 - Make sure you unplug all SATA and USB drives, the M.2 drive has to be the only drive installed.
2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.
3 - Click on secure boot option below and make sure it is set to other OS, Not windows UEFI.
4 - Click on key management and clear secure boot keys.
5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it. A Windows DVD won't work unless you've created your own UEFI Bootable DVD.
6 - Press F10 to save, exit and reboot.
7 - Windows will now start installing to your NVME drive as it has its own NVME driver built in.
8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.
9 - Click on secure boot again but now set it to WIndows UEFI mode.
10 - Click on key management and install default secure boot keys
11 - Press F10 to save and exit and windows will finish the install.

Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives. Typically you don't put anything on SATA port 1 as this is now reserved for the NVME drive and may cause a conflict (so don't use it unless you have no choice).

HWinfo can check to see if done correctly, on the bottom right of the system summary, Operating System UEFI Boot (in green) & Secure Boot (in green)

Hope you find this of help.

RedSector73, thank you; I appreciate your help.

But it didn't work. Just about to finish the newest reinstall and I'm still facing long boot times.
I took your recommendations very carefully, especially saving the secure boot keys in between the installation reboots, which was news to me, never heard of that one before (I think, probably). And I even removed my bd-drive from sata6_g1-2 just to be extra sure it wasn't even in the same namesake grouping (as I believe that it's technically sata_2 port). And also, reluctantly removed the other drives, which I didn't usually do but I already knew it was considered at least best practices, and on that topic, I even used the back panel 3.1 usb ports instead of my go-to trusty and very conveniently located ol' hub and I also didn't forget to load optimized defaults and not install it on an OC'ed system. All of this stuff, which I got away with before without a single issue.

Anyway now I think there are two possible culprits, first I think the boot times increased even more right after I installed the newest nvme driver from samsung, but i'm not too sure of that one, and second, I'll go find a way to delete old bootable mounting point entries, or whatever those are called. I first thought they were tied to the secure boot keys but that's not the case apparently.

I'll go finish up forgotten driver installations, already did the main ones, programs and tweaks, like moving user folders, symlink chrome and win temps, etc.

ps I also rolled back to bios 2501, it's much friendlier towards older ryzens.


Now the cold boot is actually manageable, I don't think I shut it down after the latest reinstall. Did it for testing. 29 seconds for the cold boot (after the post (beep)) but above one minute (~1'27") for restarts (again, after the post beep, discounting the shutdown times which are also unusually high). I'm (was :() used to sub 10" to a workable desktop after the post.

Cleared CMOS and now cold boots are fine. Windows logo, or spinning circle, doesn't even show up, straight into the user splash screen.
But restarts are still atrocious (along with shutdown time).
Tested 3 times in a row, each.

edit: rebooting from ubuntu into windows is also almost instant. Felt Like switching channels.

here try this

snappy driver installer, download the light vesrion

This program is pro at getting the best optimal drivers for your system.

Video - how to use the program

hey you're back. thanks again.
I really dislike such kind of programs, though.
I always try my best to get drivers straight from the vendors and manually, except for audio. I gave up on that horrible realtek site a long time ago, and right here actually, there's a good thread for updated ROG/realtek drivers anyway. I supposed we consider this to be a reputable source.

Came back to post some event viewer logs. Lots of entries on that section for a 6ish hours old install. Definitely plenty of degradation things in there, most of them at the 71000ms mark. All legit programas also, as msmpeng, asusthings, svchost and all. Went one by one and didn't find anything shady (in those entries, from that particular subcategory, at least). [strike]Since I couldn't find a spoiler tag I'll attach them, trying to keep it cleaner.[/strike]

was going to post 3 imgs but, well, I was only trying show things i'm finding out about now. 60 events in total, considering that fresh installs usually have lots of restarts, dunno, I still it's too much. Time tables are messed because as I said before, there was a clear cmos somewhere in there, I also didn't notice the wrong set up time zone for the most part of it.

Another thing. Things are opening in instances of 3, e.g. services.msc, regedit, .cpl things. Pretty sure I never had this happening before.

edit: i'm still running optimized defaults. i'll probably go change it right now, actually, those mem timings were making me cringe.

The source code for it is on SourceForge. Not really sure how you can be against a program that is maintained by people giving up free time to provide the best optimised drivers for free.

try this to clean up the errors, after this you may have to track down solution for each one still presenting itself, since that how you like to spend your day, should be super fun.

run as admin [powershell] (type into search bar, when you see it pop up, right click on it and run as admin)

sfc /scannnow

wait till complete
now run (still in powershell)

Dism /Online /Cleanup-Image /RestoreHealth

wait till complete

if either found and fix integrity errors or corruptions, reboot and then repeat both steps again.

came back to let you I'd give it a shot. It's that especially with driver updaters, there are a lot of "download more ram" types and "increase your pc performance with this simple tool" out there. I'm salty against a recent god awful malware thing I downloaded for my previous short lived win install, getting rid of it for sure eased the pain of having to go trough all of this again. I also kinda hated my desktop name, so rolling for a better one was also one of my priorities :cool:

yeah, running dism commands for an hour old install is pretty ironic. And I actually did that, again for the install whose name won't be missed. I don't think I did it for this one yet though, and chkdsk coupled with mem tests (outside of the ms one, which I couldn't make to run) I went through all of that for the previous install as well. No problem in running them all over again. And I'm reading a site reporting that the latest update was quite messy, I guess i'm one of the victims, seeing how these problems started very recently. Not exactly sure when but I certainly already know where to take my pitchfork. On the bright side, my ethernet looks pretty fine. Good health on that torrent.


RedSector73 wrote:

if either found and fix integrity errors or corruptions, reboot and then repeat both steps again.

I'm running the system maintenance troubleshooter as we speak. I probably shouldn't be browsing and downloading torrents while it runs... but it's taking a long time, about 40 minutes deep in now. Never ran this tool before.

first, that was degrag, fooling me. the real troubleshooter took 2 seconds and was worthless as usual.
second, after performing some of the actions RedSector73 gracefully advised, I also redid a lot of power plan tweaks, mostly going more to the default, I usually kept either a ryzen balanced or windows high perf, every other week there comes someone saying that this one better over the other, and I'm a bit gullible like that and just follow the latest trend on that, (but both tweaked down to lesser min proc). Scannow found the triple instances culprit, and dism restored it, So that was nice, now I don't open triples of service diags anymore. It was very likely just a permissions thing. Moving user folders to the same old locations from previous installs tends to do stuff like that.
After that, I unplugged every single usb (including mouse and keyboard; and rca cable) from my computer and booted into windows. After I reapplied my old OC. And now I'm quite sure that there's some option in that OC that is either the main offender in all of this or at least a contributor (it's probably from MS seeing it was all fine just a couple days ago); seeing how the cold boot times that were seemingly resolved are trash once more. I revised csm, secure boot (to uefi -- I used to keep it at "other os"), fast boot too, which reminds I made sure to turn it off from windows itself (power options, i usually don't even see it because I was used to just run powercgf hibernate off). So that was my last 2 or 3 hours. And i'm actually one step behind my earlier post... Gonna give a spin on that driver thing now.

that didn't work. Ran the sdi_snappy tool, there were 4 missing or worse drivers listed, amd sata/usb and asmedia usb x2(one of which was a downgrade, but rec'd), which then opened up another hub controller. So 5 missing drivers in total. Pretty cool, and it's portable. That's always a good sign. It's a keeper, thanks Red. Rebooted, rebooted, loaded optimized defaults, windows and rebooted, cleared cmos once again and it didn't fix the goddamned cold boot. restarted, rebooted. I was hoping that some stored value in there was acting up, but it doesn't seem to be the case. Whatever I did that fixed at least the system power on portion of it, became undone.
(isn't it a b&*** that in order to try to fix long loading times you kinda have to load a lot?)