cancel
Showing results for 
Search instead for 
Did you mean: 

[Maximus VII Ranger] solving Micro Stutter with Bios update?

iAmPengu
Level 7
Dear ROG community,

Two days ago I upgraded my old 770 to a new Gtx 1070. Before putting the card in I made sure I properly uninstalled my nvidia driver in safe mode with 'DDU'. After installing the latest nvidia driver I noticed that I suffered from micro stutter which did not occur before at all with the Gtx 770. I noticed the micro stutter happened in all the games I tried. I expected it to be a driver issue and tried multiple Nvidia drivers, from the latest to older ones which were rumored to not have micro stutters. None of the ones I tried solved my problem until I tried the 381.89 version which ironically was the one used with the older GTX 770. These are the drivers I have tried so far:

- 398.82, 398.36
- 398.11, 397.93
- 397.64, 391.35
- 391.24 ,388.43
- 388.31, 388.00, 385.69

Suspecting it might be a hardware issue with the GPU i tried benchmarks and stresstests (Heaven 4.0, Firestrike & Furmark). I did these test under stock GPU values. The results were all in line with others who have the same card and/or setup. The games I tested the separate drivers in were:

- Kingdom Come Deliverance (70-90 fps)
- Counter strike: Global Offensive (241 fps locked)
- Grand Theft Auto 5 (90-120 fps)
- Player Unknown's Battlegrounds (100-120fps)
- Borderlands 2 (241 fps locked)
- Witcher 3 (60-75fps)

The tests were done with my CPU & Ram overclocked and with everything at default/stock values did made no difference in the micro stutters. I also tried to up the Core voltage & Powerlimit to the maximum level in Msi Afterburner while downclocking the Core clock & Memory clock by -100. This also did not help. I also tried the following in the Nvidia control panel:

- Pre rendered frames 1-5
- Shader cache on/off
- Vsync is always off

At this point I am not sure whether it's a hardware fault due to the stresstests and benchmarks being in line with normal results. I am also not quite certain if its a driver issue seeing there is one driver version where the problem doesn't happen (381.89). After all these tests I was wondering if a bios update would potentially help me. With that being said, would a motherboard update potentially hurt? According to CPU-z my current bios version is: 2101 (12/12/2014)

My hardware is:
i5 4690k
16 GB ddr3 (1600mhz)
SSD (all tested games & OS are installed on this SSD)

Benq xl2420t 120hz screen (All tests were done with only this monitor attached. Secondary monitor 's hdmi cable was out and powered off)

1,258 Views
0 REPLIES 0