Showing results for 
Search instead for 
Did you mean: 

M.2 not showing in BIOS/Windows (X570)

Level 7

Im posting this here in hopes someone knows what is going on. So this week I bought a X570 board (Asus Crosshair Hero X570) and the 3700x, prior to that I was running a 1700 with the X370 variant of the board, the Hero VI.

Now the problem that encounter with the X570 board is that it doesnt pick up my m.2 drive.

I got 2 storage drives, the m.2 and the a SATA SSD. The m.2 drive is a Samsung EVO 960 500GB and the SATA SSD is a Samsung 850 EVO 250GB.

I've tried to only plug in the m.2 drive, and it does get recognized, but as soon as I plug my SSD into the motherboard, it stops recognizing it.

One time I tried to plug the SATA SSD mid-post and once I got into the bios it did recognize both drives in a "AMD-RAID" whatever that is.

Im posting here in hopes someone has some info has to why this is happening. Perhaps this needs some BIOS update?

I also tried to various sata ports and both the m.2 slots in the motherboard.

Things I did : Change the Motherboard; CSM- disable/enabled; NVMe RAID - Disable/enable; SATA- ahci/raid and still the problem persists.