cancel
Showing results for 
Search instead for 
Did you mean: 

DSL-AC51 shuts down while rebooted and dies, asks for firmware tcboot.bin?

BaraSec
Level 7
Hello everyone,

I rebooted my router (Asus DSL-AC51) yesterday and it died by itself while rebooting, not even an electricity cut. So I rebooted it manually with the switch and only the power and ethernet lights are on, I tried to ping it but it's like it's not alive, I tried to hard reset it with a pin but it does nothing even after 60 seconds, the power light doesn't flash.

Next, I shut down the router, held the reset "button", THEN I turned it on while holding the reset button. The power light was flashing immediately, jumped on my PC, gave it static IP and pinged 192.168.1.1 and it does ping, Voila! Browsed into 192.168.1.1 aaaand it showed the following:

https://i.imgur.com/4qm38Ue.png

I browsed into Asus website, downloaded the latest firmware for DSL-AC51, renamed it into tcboot.bin and uploaded it to the router on that page, waited for 5 minutes, but it did nothing, I couldn't ping or access it anymore too.

I guess tcboot.bin/tclinux.bin is something else? Where can I find it?
And what happened to my router? Indefinite hardware kernel crash?
773 Views
1 REPLY 1

BaraSec
Level 7
No one knows about this?!