cancel
Showing results for 
Search instead for 
Did you mean: 

Deleted

MoKiChU
Level 40
16,502 Views
21 REPLIES 21

Dicehunter
Level 10
I did update to the new ROG Armoury but my Spatha firmware is still at 1.58, I tried a Live Update which showed 1.72 was available but it would fail everytime.




MoKiChU wrote:
Hi,

- Go to C:\Program Files (x86)\ASUS\ROG Armoury\Mouse\ROG Spatha\Upgrade_Spatha\mouse
- Launch SPATHA Mouse Firmware Update.exe (Right click > Run as administrator)


Appreciated thank you, The firmware updated but only to 1.69 not 1.72, Did I do something wrong ?




MoKiChU wrote:
Can you try firmware update from ROG Armoury now.


I tried but it says nothing is available.

To me it looks like the wrong firmware file was bundled with the update.





Is there a way to reset or flash the Asus firmware? I'm having an issue with the wireless portion. It works fine until it sits idle for 5 or so minutes, then it won't wake up. I have to turn off the mouse and back on to get it to reset. I'm on latest version of Armory and firmware for base and mouse. I have tried going back to an earlier version of Armory but it still is an issue.

Also if I bring up the Armory software when it is wireless, the software won't load. I can get it to load by attaching the wire and turning off the base. Armory will come up. Then I unplug the wire and turn on the base to go into wireless mode and the Armory will come up. At this point I'm not sure if it is a hardware or software issue, so I figure if I flash or reset the firmware I can hopefully fix this.

All this is on a pretty fresh install of Windows 10 Pro of about 2 weeks ago. Help?]

*EDIT* I found the post on how to flash / reset the firmware. I have tried that, it reset the mouse but not the dock. I'll test it out to see if there is still an issue. Is there a way to reset the dock firmware?
Panteks Enthoo Elite / Asus x299 Rampage VI Extreme / Intel I9-7900X / Corsair Dominator RGB 3200MHz

MSI GTX 1080 TI / 2x Intel 900p / Samsung 970 Pro 512GB

Samsung 850 PRO 512GB / Western Digital Gold 8TB HD

Corsair AX 1200i / Corsair Platinum K95 / Asus Chakram

Acer XB321HK 4k, IPS, G-sync Monitor / Water Cooled / Asus G571JT Laptop

Dicehunter
Level 10
Appreciate the reply but after all this fiddling around I think it may be an issue with my windows install on my PC as I just updated it without issue on my laptop to 1.72.

Much appreciated for the help.