cancel
Showing results for 
Search instead for 
Did you mean: 

Crosshair VI Hero doesn't start | Lights ON

charchit46
Level 7
Hi everyone, my specs are-
Crosshair VI Hero WiFi
Ryzen 2700X
TridentZ 2×8GB 3600mhz C17
Gigabyte GTX 1070
Evga Supernova G3 650w
Custom water cooling or Wraith Prism cooler
970 Evo 1TB NVMe/ 240GB Zotac SATA SSD/ 2× 2TB Seagate & WD HDDs

What I did-
Removed the side panel, tried removing the SSD off m.2 slot as this board only supports single m.2 slot but I didn't had the right screwdriver for this screw type so I left it and took out the GPU, cleaned it and put it back. Didn't remove any cables other than PCIe power connector, plugged in power cable and turned it on but it didn't work.

For reference, this is what I'm facing- https://youtu.be/MiUaPt-2504
RGB lights on the motherboard still work as soon as I turn PSU on, also the green light which says CPU_Ready is working. Also there's no Error code on mobo, so I don't think it's related to BIOS.

Things I tried-
1- Removed everything, only left 24pin+8pin connector from PSU to Mobo.
2- BIOS flashbacks to latest versions and few older versions.
3- Removed the watercooling and switched to Air cooler.
4- Tried using different PSU (Corsair VS550)
5- Took the mobo & PSU off the cabinet, placed on cardboard to check if it can be a grounding issue.
6- Tried using few other tricks from youtube (Heating mobo with hairdryer, keep trying to start after PSU on/off)

Nothing worked so far, it's not related to BIOS I think as there's no error code, nothing spins not even a single fan, the cpu ready light is working, is there anything else I can try?

Any help will be appreciated, thanks!
2,515 Views
1 REPLY 1

evilkabuki
Level 7
have you tried to reseat the ram? make sure the cables are connected.check the voltages in the bios.maybe try a different ssd/hdd/m.2?