cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Z97-Pro (WiFi ac) not see my M.2 SSD drive

trodas
Level 9
Guys and gals (?), I would certaily use some help / advices, on how to make my M.2 SSD device visible in bios of my new Asus Z97-Pro (WiFi ac) mainboard.

I bought this one recently, to get a new -QUIET- build for gaming and apart from 1T WD HDD I get a 128G Samsung SM951 M.2 SSD drive. Upon inserting it into the mainboard:



...it is getting reasonably hot (especially the first chip - controller), so it should work, yet it fail to show up in the Z97-Pro bios at all. So I cannot partition the SSD, nor start installing Win7 on it.

...

I tried to set the setting in Advanced / PCH Storage Configuration - SATA Express(SATAEXPRESS) and M.2 Configuration to directly M.2 instead of Auto, but still no help. SATA is in AHCI mode.

Then I on youtube looked at this video: http://www.youtube.com/watch?v=v7PEBscJbno

...but altrought it surely help people with the Z97 Maximus VII mainboard to make the SSD visible in bios:
Advanced / Onboard Devices Configuration and change the setting of PCI Express X4_3 Slot (Black) Bandwitch from Auto Mode to M.2 Mode. However I did not find such option in my bios...

Also I noticed this thread:
http://rog.asus.com/forum/showthread.php?53091-Rampage-V-Extreme-M-2-Setup-And-Windows-Installation-...

...but this is, once again, about different mainboard - about Rampage V Extreme 😞

So, a little help would go a long way there... Thanks!


PS. Looks like I'm not alone:
https://www.ifixit.com/Answers/View/213592/Nothing+will+make+the+Asus+Z97+Pro+M.2+device+boot,+any+i...
22,170 Views
17 REPLIES 17

trodas
Level 9
Since nothing seems to help, I turn on the bios version. My board use bios version 2303 (witch is, surprisingly, not even listed on the Asus page there: http://www.asus.com/cz/Motherboards/Z97PROWiFi_ac/HelpDesk_Download/ - nothing between 2205 and 2401) and the latest is 2702. So maybe it is time to update and hope...

Sadly and very surprisingly, using the 2303 bios the updater in bios says, that the latest bios is "not a correct bios file", witch is a bit shocking. So I have two options - either I do incremental updates, or I create a USB DOS boot flash that will work.
Since my old M$ DOS one fail to start. Even unpluging all the SATA drives ended only with "Error loading the operation system" message.

So I try this DrDOS from there: http://www.biosflash.com/e/bios-boot-cd.htm
...and we see, if things get better a bit...

sk2play
Level 13
You're really pissed dude :mad:
Corsair 500R Case, H110 Hydro, 1200AX PSU, Asus Maximus Hero VI MB, Intel 4770K CPU, Gigabyte GPU GV-N98TWF3OC-6GD, G-Skill Trident 2400MHz 32GB, Crucial M500 960GB SSD, Seagate 6TB HDD x2, Creative SBZ to Denon AVR-4311ci - Infinity Primus 5.1 w/Klipsch Sub XW-300d, HP ZR30w 30" S-IPS LCD, W10 64bit

sk2play
Level 13
zipped by sk2play
Corsair 500R Case, H110 Hydro, 1200AX PSU, Asus Maximus Hero VI MB, Intel 4770K CPU, Gigabyte GPU GV-N98TWF3OC-6GD, G-Skill Trident 2400MHz 32GB, Crucial M500 960GB SSD, Seagate 6TB HDD x2, Creative SBZ to Denon AVR-4311ci - Infinity Primus 5.1 w/Klipsch Sub XW-300d, HP ZR30w 30" S-IPS LCD, W10 64bit

trodas
Level 9
Well, Im not happy, because it just fail to work and I cannot even update bios on this board. I find that a "little bit strange", that updating is not possible. On top of that, the DrDOS fail to work too, so there is no known way for me, to get a DOS working on Asus Z97-Pro board. This is a bit insane, yes...

trodas
Level 9
Oh, finally I managed to update the bios to the latest v2702 - but the issue persist.

I cannot see the M.2 SSD - not by bios, not by Mini Tool Partition Wizard Pro witch I use, because it can easily Align the SSD devices... So no solution yet.

trodas
Level 9
I wanted to install the Win7 on the M.5 Samsung 951 and I failed 😞 I tried this:
http://www.youtube.com/watch?v=No-ct8pQcIg

As this method looks very promising, however it fail to work on Asus Z97-Pro (WiFi ac)/usb 3.1 - with Samsung SM951 M.2 SSD. Rufus easily create the USB boot install Win7 Pro drive, no problemo there. However when I use the recommended bios setup, it ALWAYS reset the computer right after the "Starting Windows" message on screen appears. After that, the Asus board tell me, that it adjusted my bios settings to make the problem "go away" (it re-enable the CSM!) and then the install works, however it did not see single drive 😞 (all except M.2 are unpluged)

Latest bios are now used. Asked Asus support and get funny message, that basically says, that Asus only support following M.2 SSD drives it list there: http://www.mediafire.com/?tgzauc1phpnu21w
And the best part of the message is: "Asus do not guarantee functionality of this manboard with other that listed M.2 SSD drives." WTF ...

Any help will be greatly appreciated.

I tried different bios settings regarding the CSM, but the rule seems to be that disabled CSM lead to reboot 😞

The guide is basically about that for the first part of Win install on M.2 SSD drive, you need to:
- completely disable CSM (Boot/CSM)
- select Secure Boot to "Other OS"
- select Key Management to "Clear Secure Bootkeys"

...install Win thru first reboot, then...

Secure Boot: Windows UEFI Mode (instead of completely disabling CSM)
Key Management: Install Default Secure Boot Keys

So it was sound reasonable, however it failed completely 😞

Breimeister
Level 9
Idon't know if this information will help you or not as I don't have this motherboard but here is how I got the Samsung 950 Pro M.2 X4 working on my machine. I had to convert the SSD from GPT to MBR. Then I had to enable CSM. As a precaution I removed all the other hard drives from my system before I used the Windows install DVD. If Windows does not see your SSD, you may have to load a driver. At that stage I had the installer delete all the partitions on that SSD and then installed Windows 10 Pro. I know you have Windows 7 Ultimate but as long as you loaded the driver it should work too.

After everything was installed, I reconnected all the other drives and everything is fine.

Good luck and Merry Christmas!

trodas
Level 9
Witch driver you recommend me to load during the setup? I already converted (following the guide) the Win7 install to the USB stick, so I have to connect the DVDROM drive for the driver, I presume. But WHAT driver is need to the install see the M.2 device?
ATM it did not see anything.

Asus support tell me, that they ONLY support the M.2 SSDs, mentioned in this pdf:
http://dlcdnet.asus.com/pub/ASUS/mb/LGA1150/Z97-PRO%28Wi-Fi_ac%29_USB_31/Z97-PRO-WiFi-AC-USB31_Devic...

Therefore only supported (according to Asus) M.2 SSDs in Asus Z97-Pro(WiFi ac/USB 3.1 mainboard are:

Apacer: T60 A200-M 128G
Intel: 530 SSDSCKGW080A401 80GB
Liteon: LITEON-LGT-256M6G-2280-256GB
Kingston: RBU-SNS6100S3/128GC-2260-128GB and RBU-SNS6100S3/256GC-2260-256GB
Sandisk: X110-2260-128GB and X110-2260-256GB
Samsung: MZ-NPD1280-2280-128GB (Support on ISRT 13.1)

None of these SSDs are particulary interesting in terms of speed...

Breimeister
Level 9
I e-mailed you the driver I found for my Samsung 950 Pro M.2 SSD. I don't know if Windows will see your SSD after you load it, but it can't hurt to try.

I tried but your Hotmail.com e-mail address is not available. 😞