Showing results for 
Search instead for 
Did you mean: 

Access ROG Forum using Tapatalk [Service Suspended]

Level 10
A quick guide to explain how to access ROG forum on the go.

1) Download Tapatalk in Google Play Store or iOS Store


2) Open the app and go to Following and click the Search button.


3) Search for "ASUS ROG" and Click "Follow"


4) Go back in the Following tab. ASUS ROG appears. Click on ASUS ROG to access the forum.


5) You can navigate on the different forum categories. A pop-up window will appear to log-in.


6)To log-in into the forum, enter your email address and password you are using usually on the desktop version. Best is to create a Tapatalk account to remember your log-in for the different forum you will follow.


7) If you want to receive notifications for a specific topic, click on the subscribe button on the top right. In that case, I am following Overclocking & Tweaking


😎 Next time you will access the Following tab, the topic subscribed will appears. It will also show in your feed.

And don't forget, Keep pushing it !

Hi Akane !

Nice guide, short, sweet and to the point.

Thank you for this. 🙂

Level 7
Thx for this guide 🙂
Pirates Live For Ever So Do Names Man Behind It Not


I have problems in Tapatalk. It loads forever and doesn't show anything. Two days ago it worked but pushed me to enter the password every time. The Unread tab doesn't work at all.*

I know this is a couple years old but their seems to be issues when trying to use tapatalk.

Basically it wont let me log into the forum. I get a popup with something along the lines of......action not supported, forum is using older version.....or something like that.

I can browse no problem, just can't log in and post.


Replying does not work.

shamandgg wrote:
Replying does not work.
It does. It is what i am doing right now. Nonetheless it is buggy. I know if i connect to rog forum through my pc i will have to reconnect in tapatalk (use disconnect then reconnect with your credentials).

Also most pictures link are broken via tapatalk. Not all but 90% for sure.

Their plugin must be outdated.

Are you listening modo? Can you check this with the forum administrator? 😛

Not applicable
Helpful, Thanks

Level 7
Boys I downloaded it but it presents thousands of errors. I've talked to people who worked for them at the beginning and not now. Will there be another?

Thank you all!

Yep - Tapatalk is not working well. I get notifications, but the contents of posts load forever. Very useless at the moment - I need to go back to the browser.