cancel
Showing results for 
Search instead for 
Did you mean: 

Z690A-D4 WHEA 17 and System Reboot/Freeze

BattlePhenom
Level 8
Hi,

I'm having an issue where my system completely locks up randomly. I've tried various trouble shooting methods, updated drivers, updated firmware, and have even done a fresh install of Windows 11, yet the issue persists. I've tried disabling PCI Native Power Management and PCI clock gating in bios. All this does, however, is just get rid of the WHEA Logger 17 errors, but I still get Event ID 41 Critical error.

My Specs:
RTX 4090
I9-13900KF
(4x8GB) 32GB DDR4 4000 CL17
EVGA 1000W 80 Plus Gold PSU
OS Win11 Latest 22H2 build
Main drive Seagate Firecuda 520 2TB NVMe

Previously, I've never had this issue and it only started happening recently when I upgraded my 12900K to a 13900KF and updated my Bios from 0807 to 2204 in January 2023. I followed instructions carefully when updating Bios and installed all the necessary drivers and firmware's associated with the Z690 MB I have. I'm on the latest Nvidia driver also.

The behavior is very random I can go a whole day without it happening then suddenly it'll pop up. This often happens when the system is under Idle to low load power and performance wise, although it has happened while gaming too.

I've done a complete physical system sweep to check cables are firmly plugged in and I've dusted and cleaned with canned air and everything I've done points back to the CPU, Bios, Firmware, and drivers I've updated recently. This last time with a fresh W11 install I let Armoury Crate handle the chipset, Intel ME, and other drivers to download and install and yet the same WHEA Logger 17 has popped up.

Here are details of the error:

A corrected hardware error has occurred.

Component: PCI Express Root Port
Error Source: Advanced Error Reporting (PCI Express)

Primary Bus:Device:Function: 0x0:0x1:0x0
Secondary Bus:Device:Function: 0x0:0x0:0x0
Primary Device Name:PCI\VEN_8086&DEV_A70D&SUBSYS_86941043&REV_01
Secondary Device Name:

ASUS please address and fix this issue as I've seen many others experience this on ASUS Z690 MB's.
1,007 Views
1 REPLY 1

Jiaszzz_ROG
Customer Service Agent
Hello, BattlePhenom.

May I ask if you have checked the device manager to see if there are any drivers that have not been updated?
For example, is there an exclamation mark in other devices > PCIE-related items?
Do you have enable the PCI Express Root Port?

According to the memory QVL list of the ROG STRIX Z690-A GAMING WIFI D4, G.SKILL F4-4000C15Q-32GTZR is listed, but it seems difficult to tell whether it is the model based on the memory information you provided.
It is recommended that you start by using the memory from the QVL list, then try installing one module at a time until you have installed the full kit using the recommended slots as listed in the motherboard user manual, and finally reset the BIOS settings to see if the error reappears.
If possible, please provide a screenshot of the error message.

Thank you.
sharing complete hardware info & software config details will help us better understand the issue 🙂