Showing results for 
Search instead for 
Did you mean: 

Z690 Strix-E, ThunderboltEx4, and Win11

Level 8
Anyone manage to get the ThunderboltEX4 working under windows 11?

ROG Strix 690-E Motherboard, 12900K, 64G DDR5 (matched pair G.Skill)
ThunderboltEx4 plugged into the bottom PCI slot, attached with USB, TB-header, and Power.

I've walked through uninstalling/installing all of the intel drivers multiple times. Up to Date BIOS. Up to date in Windows Update. Up to date in Armoury Crate

With "Discrete Thunderbolt" [Disabled] -> Thunderbolt shows up in Control Center Loads, and I can see the attached devices with status "Not Connected". Clicking over to "Approve Devices" stalls on a blank page. About shows App version Controller 1.41.1193.0. And PCIE tunneling is "Disabled". The Controller shows as Thunderbolt 4 (1137), 2 ports, and NVM Firmware Version 31.0

Toggling "Discrete Thunderbolt" [Enabled] breaks the driver (I still get DisplayPort Passthrough). So I get a broken driver in Device Manager. Thunderbolt Control Center is not installed. etc. If I manually install/run the Control Center app I can navigate to Approve (not in the semi-working case this page is blank), but there are no devices recognized.

I'm stuck in a trap that I can see the devices, but I can't Approve them to connect.

Customer Service Agent
Hello, Pedro Sanchez.

May I ask if the problem happens when you first build? Or does it happen after a software or hardware change?
Could you help to confirm the question below for us to better understand the configuration details?
- the full model name of your motherboard and the current BIOS version
- the content of the setting in BIOS (or whether it is the default)
- the brand and model name of the CPU, DRAM, GPU, and PSU currently installed
- the OS version and OS build

Thank you.

Level 7

My friend SuddenSaturn, we are all stuck,  supporty for this item is very very poor or NUL, i gave up, using as USB type-C instead. Every one has the same problem and no solution from Asus, but still they keep on selling it...

Level 7

I was dealing with this exact same issue. I am running an ASUS ROG  Z690-E, with 128 GB Corsair RAM and an installed Thunderbolt EX4 card. After hours dealing with the same problems i logged into my Motherboard BIOS and enabled Discreet Thunderbolt setting and it fixed all this issues with me. I now have 2 thunderbolt devices connected and working. 1 being a 72 TB OWC raid and it works fine and daisy chains as well.

Thank you for sharing. I do have discrete thunderbolt enabled all the time, still not showing, although TYPE-C is working which I am using. I also came across some one who changed the slot of the card to another slot and seemed to work, is just a peety that asus as a famous brand i get the feeling they are looking in the other direction, almost everyone has an issue of same sort. Thank you I will keep on trying.. I am glad for you 🙂