Showing results for 
Search instead for 
Did you mean: 

Z390-A USB-C Port Works only with Phone, not Headphones --New Problem

Level 7
I was using the USB-C port on the Z390-A to charge my Sennheiser Momentum 3 headphones and to listen to audio on the PC at night. It recently stopped working and since the summer, I have not been able to use or even charge the headphones. The same cable, when connected to my Galaxy Note 10+, both charges the phone AND does data transfers.
I tried another cable and another port and the headphones work on other ports, just no longer on the USB-C port that used to be my dedicated headphone port.

Also, the port physically next to the USB-C port seems to be intermittent and now completely dead. Nothing I plug into it is detected.

I've tried uninstalling all the root hub drivers and rebooting, but the ports continue to behave in this odd manner. Until I solve this, i need to buy a port expander so I can connect the devices I need--I don't have enough ports because these two no longer work.

Any other suggestions or is my hardware just dead?
"If it doesn't cause an earthquake, you need a bigger subwoofer."

Customer Service Agent
Hi Basspig:
Thanks for reaching us , follow your description , yes, I think it's hardware malfunction, too. Before you issue rma , please don't give up to update BIOS/USB driver and windows update to try software solution.