cancel
Showing results for 
Search instead for 
Did you mean: 

VPN not working on Zephyrus m16, ASUS software issue

lazyllama
Level 7
I have an l2tp vpn set up correctly but it simply cannot make a connection outside the system. Something is blocking the connection on this laptop because it works on all my other systems. I set the registry key to go outside the nat (AssumeUDPEncapsulationContextOnSendRule DWORD=2). I opened all the necessary firewall ports but nothing works. I noticed when I ran netstat -ano asus' AutoConnectHelper.exe was using the VPN ports when initiating the VPN connection which is why this is clearly an asus software problem. I disabled AutoConnectHelper.exe by renaming it and restarting, and now I see svchost.exe using the vpn ports which is what I would expect, but VPN still doesn't work. Has anyone else experienced this issue? What is AutoConnectHelper and why does it interfere with the vpn connection?
1,078 Views
5 REPLIES 5

xeromist
Moderator
I believe that executable is a component of Armoury Crate. You can try uninstalling the entire Crate software package to see if that makes a difference.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Blake1
Level 10
Hello lazyllama,
Can you share more about how you set up the VPN?
Which app are you using?
Can you share some screenshot of the setting and the error?
Thank you.

I'm using the built in windows 10 vpn.
I click add a VPN connection and fill out all the info. I verified the info is connect, the vpn server doesn't even see this laptop connect so it's something locally and it's caused by armory crate because it works before armory crate is installed. The problem is even if I uninstall armory crate afterwards it doesn't work so it changes some setting and doesn't clean up properly.

The vpn uses UDP ports 500, 1701 and 4500. Why do I see AutoConnectHelper.exe using these ports when I try to initiate a VPN connection?

Blake1
Level 10
Hello lazyllama,
Can you share some screenshot?
If you don't want to make it public, you can PM me.
And how did you uninstall Armoury Crate? by our uninstall tool?
We do see that sometime uninstallation might left some files in the computer,
you can try Geek uninstaller to double check if all armoury crate related files are still there.

One more thing. When you first go this device, there is already Armoury Crate inside.
Does the VPN work at that time? does the issue happen after certain update?
Thank you.

PM Sent.